summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--3.patch23
-rw-r--r--php-horde-Horde-Image.spec14
2 files changed, 7 insertions, 30 deletions
diff --git a/3.patch b/3.patch
deleted file mode 100644
index 9187080..0000000
--- a/3.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 5cbb8d0ab64912e56f3152d3b296eef3627e95c6 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 17 Oct 2019 12:53:28 +0200
-Subject: [PATCH] Fix Array and string offset access syntax with curly braces
- is deprecated
-
----
- lib/Horde/Image/Exif/Parser/Gps.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/Horde/Image/Exif/Parser/Gps.php b/lib/Horde/Image/Exif/Parser/Gps.php
-index 1b90d94..4357255 100644
---- a/lib/Horde/Image/Exif/Parser/Gps.php
-+++ b/lib/Horde/Image/Exif/Parser/Gps.php
-@@ -152,7 +152,7 @@ protected function _formatData($type, $tag, $intel, $data)
- case 'ASCII':
- // Latitude Reference, Longitude Reference
- if ($tag == '0001' || $tag == '0003') {
-- $data = ($data{1} == $data{2} && $data{1} == $data{3}) ? $data{0} : $data;
-+ $data = ($data[1] == $data[2] && $data[1] == $data[3]) ? $data[0] : $data;
- }
- break;
-
diff --git a/php-horde-Horde-Image.spec b/php-horde-Horde-Image.spec
index 1724abf..8da4696 100644
--- a/php-horde-Horde-Image.spec
+++ b/php-horde-Horde-Image.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Image
#
-# Copyright (c) 2012-2019 Nick Bebout, Remi Collet
+# Copyright (c) 2012-2020 Nick Bebout, Remi Collet
#
# License: MIT
# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
@@ -13,16 +13,14 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-horde-Horde-Image
-Version: 2.6.0
-Release: 4%{?dist}
+Version: 2.6.1
+Release: 1%{?dist}
Summary: Horde Image API
License: GPLv2+ and LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/horde/Image/pull/3.patch
-
BuildArch: noarch
BuildRequires: gettext
BuildRequires: php(language) >= 5.3.0
@@ -93,13 +91,11 @@ Optional dependency: php-pecl-imagick
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1 -b .pr3
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/.htaccess/d' \
- -e '/Gps.php/s/md5sum=.*name=/name=/' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -171,6 +167,10 @@ fi
%changelog
+* Fri Mar 13 2020 Remi Collet <remi@remirepo.net> - 2.6.1-1
+- update to 2.6.1
+- drop patch merged upstream
+
* Thu Oct 17 2019 Remi Collet <remi@remirepo.net> - 2.6.0-4
- add patch for PHP 7.4 from
https://github.com/horde/Image/pull/3