summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-11 19:05:17 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-11 19:05:17 +0100
commit1ea98747a799bf603f6a2e2c2027f8c45a908433 (patch)
tree2052c7eb8bb17b9ec42e3d0d01660c2c32cd0f56
parente067e3662905a16674e79469d65ba3e052b67669 (diff)
php-horde-Horde-Icalendar: add patch for PHP 5.3
-rw-r--r--Horde_Icalendar-pr213.patch31
-rw-r--r--php-horde-Horde-Icalendar.spec11
2 files changed, 42 insertions, 0 deletions
diff --git a/Horde_Icalendar-pr213.patch b/Horde_Icalendar-pr213.patch
new file mode 100644
index 0000000..4b63001
--- /dev/null
+++ b/Horde_Icalendar-pr213.patch
@@ -0,0 +1,31 @@
+From 7daa8bb0e41a35337e3181001e980e99ffca745d Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Sat, 11 Feb 2017 18:53:57 +0100
+Subject: [PATCH] fix PHP 5.3 compatibility
+
+---
+ framework/Icalendar/lib/Horde/Icalendar.php | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/framework/Icalendar/lib/Horde/Icalendar.php b/framework/Icalendar/lib/Horde/Icalendar.php
+index ddb860d..ab5155b 100644
+--- a/framework/Icalendar/lib/Horde/Icalendar.php
++++ b/framework/Icalendar/lib/Horde/Icalendar.php
+@@ -1289,7 +1289,7 @@ function($a, $b) {
+ if (!$b['end']) {
+ return -1;
+ }
+- return $this->_getEndDifference($a['end'], $b['end']);
++ return Horde_Icalendar::_getEndDifference($a['end'], $b['end']);
+ }
+ );
+
+@@ -1365,7 +1365,7 @@ protected function _checkEndDate($t, $times)
+ *
+ * @return boolean True if $a < $b otherwise false.
+ */
+- protected function _getEndDifference($a, $b)
++ public static function _getEndDifference($a, $b)
+ {
+ if (strlen($a) == 4) {
+ $a = @gmmktime(0, 0, 0, 1, 1, $a);
diff --git a/php-horde-Horde-Icalendar.spec b/php-horde-Horde-Icalendar.spec
index 95b91f0..a0027ac 100644
--- a/php-horde-Horde-Icalendar.spec
+++ b/php-horde-Horde-Icalendar.spec
@@ -21,6 +21,9 @@ License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# https://github.com/horde/horde/pull/213
+Patch0: %{pear_name}-pr213.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
@@ -63,11 +66,13 @@ An API for dealing with iCalendar data.
%prep
%setup -q -c
cd %{pear_name}-%{version}
+%patch0 -p3 -b .pr213
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ -e '/Icalendar.php/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -102,6 +107,11 @@ done | tee ../%{pear_name}.lang
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+%if 0%{?rhel} == 6
+sed -e 's/testLineFolding/SKIP_testLineFolding/' \
+ -i ExportTest.php
+%endif
+
ret=0
for cmd in php56 php70 php71 php; do
if which $cmd; then
@@ -136,6 +146,7 @@ fi
%changelog
* Sat Feb 11 2017 Remi Collet <remi@fedoraproject.org> - 2.1.5-1
- Update to 2.1.5
+- open https://github.com/horde/horde/pull/213 - PHP 5.3 compatibility
* Mon Mar 21 2016 Remi Collet <remi@fedoraproject.org> - 2.1.4-1
- Update to 2.1.4