summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-25 08:20:35 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-25 08:20:35 +0100
commit1a4523fc88309ab1c60735a841650fcec9459c75 (patch)
treecafe7742abc9bb09f7fba05e6ff2234d8153f328
parent7ac03df498a8802474ce104abe318369a0f222ad (diff)
php-horde-Horde-Icalendar: add upstream patch for recent Horde_Mime
-rw-r--r--Horde_Icalendar-upstream.patch70
-rw-r--r--php-horde-Horde-Icalendar.spec13
2 files changed, 80 insertions, 3 deletions
diff --git a/Horde_Icalendar-upstream.patch b/Horde_Icalendar-upstream.patch
new file mode 100644
index 0000000..7852a7b
--- /dev/null
+++ b/Horde_Icalendar-upstream.patch
@@ -0,0 +1,70 @@
+From 74e4d976a4ad5e56daebe6bff4e95510bb05375f Mon Sep 17 00:00:00 2001
+From: Michael M Slusarz <slusarz@horde.org>
+Date: Mon, 29 Sep 2014 17:02:53 -0600
+Subject: [PATCH] Don't use Horde_Mime::quotedPrintableEncode().
+
+Horde_Mime is no longer a direct dependency of Icalendar
+---
+ framework/Icalendar/lib/Horde/Icalendar.php | 2 +-
+ framework/Icalendar/package.xml | 7 -------
+ 2 files changed, 1 insertion(+), 8 deletions(-)
+
+diff --git a/framework/Icalendar/lib/Horde/Icalendar.php b/framework/Icalendar/lib/Horde/Icalendar.php
+index e1a2993..6291ef8 100644
+--- a/framework/Icalendar/lib/Horde/Icalendar.php
++++ b/framework/Icalendar/lib/Horde/Icalendar.php
+@@ -1116,7 +1116,7 @@ protected function _exportvData($base = 'VCALENDAR')
+ $result .= $name . $params_str . ':'
+ . preg_replace(array('/(?<!\r)\n/', '/(?<!=)\r\n/'),
+ array("\r\n", "=0D=0A=\r\n "),
+- Horde_Mime::quotedPrintableEncode($value))
++ quoted_printable_encode($value))
+ . $this->_newline;
+ } else {
+ $attr_string = $name . $params_str . ':' . $value;
+From 706bed2729d4ac0230e467b635a5beaa8748469f Mon Sep 17 00:00:00 2001
+From: Michael M Slusarz <slusarz@horde.org>
+Date: Thu, 2 Oct 2014 00:56:14 -0600
+Subject: [PATCH] QP encoding has slightly changed
+
+---
+ .../Icalendar/test/Horde/Icalendar/fixtures/line-folding-4.ics | 6 +++---
+ .../Icalendar/test/Horde/Icalendar/fixtures/line-folding-5.ics | 10 +++++-----
+ 2 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/framework/Icalendar/test/Horde/Icalendar/fixtures/line-folding-4.ics b/framework/Icalendar/test/Horde/Icalendar/fixtures/line-folding-4.ics
+index 76e1346..48d9c4b 100644
+--- a/framework/Icalendar/test/Horde/Icalendar/fixtures/line-folding-4.ics
++++ b/framework/Icalendar/test/Horde/Icalendar/fixtures/line-folding-4.ics
+@@ -5,8 +5,8 @@ BEGIN:VEVENT
+ UID:XXX
+ DTSTART:20080101T000000
+ DTSTAMP:20080101T000000
+-DESCRIPTION;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:L=C3=B6rem ips=C3=BCm d=C3=B6l=C3=B6r sit =C3=A4met, c=C3=B6nsectet=C3=BCer =
+-=C3=A4dipiscing elit. Aliq=C3=BC=C3=A4m s=C3=B6llicit=C3=BCdin f=C3=A4=C3=BC=
+-cib=C3=BCs m=C3=A4=C3=BCris =C3=A4met.
++DESCRIPTION;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:L=C3=B6rem ips=C3=BCm d=C3=B6l=C3=B6r sit =C3=A4met, c=C3=B6nsectet=C3=
++=BCer =C3=A4dipiscing elit. Aliq=C3=BC=C3=A4m s=C3=B6llicit=C3=BCdin f=
++=C3=A4=C3=BCcib=C3=BCs m=C3=A4=C3=BCris =C3=A4met.
+ END:VEVENT
+ END:VCALENDAR
+diff --git a/framework/Icalendar/test/Horde/Icalendar/fixtures/line-folding-5.ics b/framework/Icalendar/test/Horde/Icalendar/fixtures/line-folding-5.ics
+index 1cfbd12..f2d1157 100644
+--- a/framework/Icalendar/test/Horde/Icalendar/fixtures/line-folding-5.ics
++++ b/framework/Icalendar/test/Horde/Icalendar/fixtures/line-folding-5.ics
+@@ -5,10 +5,10 @@ BEGIN:VEVENT
+ UID:XXX
+ DTSTART:20080101T000000
+ DTSTAMP:20080101T000000
+-DESCRIPTION;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:L=C3=B6remips=C3=BCmd=C3=B6l=C3=B6rsit=C3=A4met,c=C3=B6nsectet=C3=BCer=C3=A4=
+-dipiscingelit.Aliq=C3=BC=C3=A4ms=C3=B6llicit=C3=BCdinf=C3=A4=C3=BCcib=C3=BCs=
+-m=C3=A4=C3=BCris=C3=A4met. L=C3=B6remips=C3=BCmd=C3=B6l=C3=B6rsit=C3=A4met,c=
+-=C3=B6nsectet=C3=BCer=C3=A4dipiscingelit.Aliq=C3=BC=C3=A4ms=C3=B6llicit=C3=
+-=BCdinf=C3=A4=C3=BCcib=C3=BCsm=C3=A4=C3=BCris=C3=A4met.
++DESCRIPTION;CHARSET=UTF-8;ENCODING=QUOTED-PRINTABLE:L=C3=B6remips=C3=BCmd=C3=B6l=C3=B6rsit=C3=A4met,c=C3=B6nsectet=C3=BCer=
++=C3=A4dipiscingelit.Aliq=C3=BC=C3=A4ms=C3=B6llicit=C3=BCdinf=C3=A4=C3=BCcib=
++=C3=BCsm=C3=A4=C3=BCris=C3=A4met. L=C3=B6remips=C3=BCmd=C3=B6l=C3=B6rsit=
++=C3=A4met,c=C3=B6nsectet=C3=BCer=C3=A4dipiscingelit.Aliq=C3=BC=C3=A4ms=
++=C3=B6llicit=C3=BCdinf=C3=A4=C3=BCcib=C3=BCsm=C3=A4=C3=BCris=C3=A4met.
+ END:VEVENT
+ END:VCALENDAR
diff --git a/php-horde-Horde-Icalendar.spec b/php-horde-Horde-Icalendar.spec
index 695198c..487cced 100644
--- a/php-horde-Horde-Icalendar.spec
+++ b/php-horde-Horde-Icalendar.spec
@@ -13,7 +13,7 @@
Name: php-horde-Horde-Icalendar
Version: 2.0.9
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: iCalendar API
Group: Development/Libraries
@@ -21,6 +21,8 @@ License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+Patch0: %{pear_name}-upstream.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
@@ -45,8 +47,6 @@ Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Mail) < 3.0.0
-Requires: php-pear(%{pear_channel}/Horde_Mime) >= 2.0.0
-Requires: php-pear(%{pear_channel}/Horde_Mime) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Support) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
@@ -65,10 +65,13 @@ An API for dealing with iCalendar data.
%setup -q -c
cd %{pear_name}-%{version}
+%patch0 -p3 -b .upstream
+
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ -e 's/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
@@ -131,6 +134,10 @@ fi
%changelog
+* Tue Nov 25 2014 Remi Collet <remi@fedoraproject.org> - 2.0.9-2
+- add upstream patch (thanks Koschei)
+- drop dependency on Horde_Mime
+
* Wed Jun 04 2014 Remi Collet <remi@fedoraproject.org> - 2.0.9-1
- Update to 2.0.9