summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-03-04 07:54:45 +0100
committerRemi Collet <fedora@famillecollet.com>2015-03-04 07:54:45 +0100
commit3dd54559b7794797dadb0a508694e4433f7d924e (patch)
treead3fcd47d866800fa6ec7e313b88d37caf43e004
parent667c3592cc6727e2cc1f852c606c043b24baf4a2 (diff)
php-horde-Horde-Http: 2.1.4
-rw-r--r--Horde_Http-pr125.patch21
-rw-r--r--php-horde-Horde-Http.spec13
2 files changed, 32 insertions, 2 deletions
diff --git a/Horde_Http-pr125.patch b/Horde_Http-pr125.patch
new file mode 100644
index 0000000..518d67c
--- /dev/null
+++ b/Horde_Http-pr125.patch
@@ -0,0 +1,21 @@
+From c4221e8ddc0ab6b3f4f5e3ded80f4ef7501788f1 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 4 Mar 2015 07:44:15 +0100
+Subject: [PATCH] this test requires configuration
+
+---
+ framework/Http/test/Horde/Http/TestBase.php | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/framework/Http/test/Horde/Http/TestBase.php b/framework/Http/test/Horde/Http/TestBase.php
+index 14b3c92..29b3c37 100644
+--- a/framework/Http/test/Horde/Http/TestBase.php
++++ b/framework/Http/test/Horde/Http/TestBase.php
+@@ -38,6 +38,7 @@ public function setUp()
+
+ public function testRequest()
+ {
++ $this->_skipMissingConfig();
+ $client = new Horde_Http_Client(
+ array('request' => new self::$_requestClass())
+ );
diff --git a/php-horde-Horde-Http.spec b/php-horde-Horde-Http.spec
index 1b559e8..3c6aa5c 100644
--- a/php-horde-Horde-Http.spec
+++ b/php-horde-Horde-Http.spec
@@ -18,7 +18,7 @@
%endif
Name: php-horde-Horde-Http
-Version: 2.1.3
+Version: 2.1.4
Release: 1%{?dist}
Summary: Horde HTTP libraries
@@ -27,6 +27,9 @@ License: BSD
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# https://github.com/horde/horde/pull/125
+Patch0: %{pear_name}-pr125.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
@@ -67,7 +70,9 @@ Optional dependency: php-pecl-http or php-pecl-http1
%setup -q -c
cd %{pear_name}-%{version}
-mv ../package.xml %{name}.xml
+%patch0 -p3 -b .pr125
+sed -e '/TestBase.php/s/md5sum="[^"]*"//' \
+ ../package.xml > %{name}.xml
%build
@@ -117,6 +122,10 @@ fi
%changelog
+* Wed Mar 04 2015 Remi Collet <remi@fedoraproject.org> - 2.1.4-1
+- Update to 2.1.4
+- open https://github.com/horde/horde/pull/125
+
* Thu Jan 08 2015 Remi Collet <remi@fedoraproject.org> - 2.1.3-1
- Update to 2.1.3
- add provides php-composer(horde/horde-http)