summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-01 12:33:27 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-01 12:33:27 +0100
commit24893da0353096170636693e45c8b02548f338fc (patch)
treea6bc127adeec7489ea8acfc0c5f08c443bdfe8aa
parent20e3d57db330edfd401e643792a95d0f596a3799 (diff)
Update php-horde-Horde-* to 2.0.0
-rw-r--r--php-horde-Horde-Http.spec46
1 files changed, 28 insertions, 18 deletions
diff --git a/php-horde-Horde-Http.spec b/php-horde-Horde-Http.spec
index 72dcd3b..85e8735 100644
--- a/php-horde-Horde-Http.spec
+++ b/php-horde-Horde-Http.spec
@@ -1,9 +1,11 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Http
+%global pear_name Horde_Http
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Http
-Version: 1.1.1
-Release: 2%{?dist}
+Version: 2.0.0
+Release: 1%{?dist}
Summary: Horde HTTP libraries
Group: Development/Libraries
@@ -13,27 +15,32 @@ Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Support) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Requires: php-channel(pear.horde.org)
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
%description
This package provides a set of classes for making HTTP requests.
+
%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
%build
@@ -43,14 +50,14 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -59,7 +66,7 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
%files
@@ -71,6 +78,9 @@ fi
%{pear_testdir}/Horde_Http
%changelog
+* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Tue Aug 14 2012 Remi Collet <remi@fedoraproject.org> - 1.1.1-2
- rebuilt for new pear_testdir