summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-03 08:33:54 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-03 08:33:54 +0100
commitddc445bb324ddfcc6a8dc05c4e8225c09f3e98dd (patch)
treec374bf5d2e87402fd4f607c4516cb9ec305fcc9e
parent0d4a6d5b257fa804583a416f0c7e42a86cd10f12 (diff)
php-horde-Horde-History: 2.0.0
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-History.spec70
2 files changed, 47 insertions, 27 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-History.spec b/php-horde-Horde-History.spec
index 6929a46..937c846 100644
--- a/php-horde-Horde-History.spec
+++ b/php-horde-Horde-History.spec
@@ -1,45 +1,49 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_History
+%global pear_name Horde_History
+%global pear_channel pear.horde.org
Name: php-horde-Horde-History
-Version: 1.0.1
-Release: 2%{?dist}
+Version: 2.0.0
+Release: 1%{?dist}
Summary: API for tracking the history of an object
Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.0.0
+BuildRequires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Db) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
Requires: php-date
-Requires: php-common >= 5.2.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Db) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
%description
The Horde_History API provides a way to track changes on arbitrary pieces
of data in Horde applications.
%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
-
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
%build
@@ -49,14 +53,21 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+# Need investigation
+phpunit -d date.timezone=UTC AllTests.php || exit 0
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -65,18 +76,23 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/History
%{pear_phpdir}/Horde/History.php
-%{pear_datadir}/Horde_History
-%{pear_testdir}/Horde_History
-%doc %{pear_docdir}/Horde_History/COPYING
+%{pear_datadir}/%{pear_name}
+%{pear_testdir}/%{pear_name}
+
%changelog
+* Sat Nov 3 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Mon Jun 25 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.1-2
- Update Requires