summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-02-10 18:01:19 +0100
committerRemi Collet <fedora@famillecollet.com>2013-02-10 18:01:19 +0100
commit451d0f8742f6f22dda60ac4de6f7bc3418449b4f (patch)
tree234ff7919a5b494a7ec0985d26181209a81f0e36
parent31a64953c80dfd74baa67a2a51a7c0da5a9829d3 (diff)
php-horde-Horde-History: cleanups
-rw-r--r--php-horde-Horde-History.spec40
1 files changed, 26 insertions, 14 deletions
diff --git a/php-horde-Horde-History.spec b/php-horde-Horde-History.spec
index e889c1a..2810bb4 100644
--- a/php-horde-Horde-History.spec
+++ b/php-horde-Horde-History.spec
@@ -5,17 +5,18 @@
Name: php-horde-Horde-History
Version: 2.0.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: API for tracking the history of an object
Group: Development/Libraries
-License: LGPLv2+
-URL: http://pear.horde.org
+License: LGPLv2
+URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear
+BuildRequires: php-common >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
# To run unit tests
BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
@@ -23,8 +24,10 @@ BuildRequires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php(language) >= 5.3.0
+Requires: php-common >= 5.3.0
Requires: php-date
+Requires: php-spl
+Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/Horde_Db) >= 2.0.0
Conflicts: php-pear(%{pear_channel}/Horde_Db) >= 3.0.0
@@ -38,9 +41,9 @@ Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
The Horde_History API provides a way to track changes on arbitrary pieces
of data in Horde applications.
+
%prep
-%setup -q -c -T
-tar xif %{SOURCE0}
+%setup -q -c
cd %{pear_name}-%{version}
cp ../package.xml %{name}.xml
@@ -64,12 +67,17 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
+src=$(pwd)/%{pear_name}-%{version}
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+
# Need investigation
-phpunit\
- -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+# InvalidArgumentException: The guid needs to be a string!
+sed -e 's/testMethodLogHasParameterStringGuid/SKIP_TEST_testMethodLogHasParameterStringGuid/' -i InterfaceTest.php
+
+phpunit \
+ -d include_path=$src/lib:.:%{pear_phpdir} \
-d date.timezone=UTC \
- . || exit 0
+ .
%post
@@ -82,6 +90,7 @@ if [ $1 -eq 0 ] ; then
%{pear_channel}/%{pear_name} >/dev/null || :
fi
+
%files
%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
@@ -93,11 +102,14 @@ fi
%changelog
-* Mon Nov 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.1-1
-- Update to 2.0.1 for remi repo
+* Sun Feb 10 2013 Remi Collet <remi@fedoraproject.org> - 2.0.1-2
+- cleanups for review
+
+* Mon Nov 19 2012 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- Update to 2.0.1
-* Sat Nov 3 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
-- Update to 2.0.0 for remi repo
+* Sat Nov 3 2012 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- Update to 2.0.0
* Mon Jun 25 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.1-2
- Update Requires