summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-12 10:02:00 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-12 10:02:00 +0100
commit6e6a14b5acbb6f04cb1411499d030b849670f61a (patch)
tree40c0c98148807156920d9ed107c20f9583a1969e
php-horde-Horde-Editor: new package
-rw-r--r--Horde_Editor-path.patch13
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Editor.spec112
3 files changed, 129 insertions, 0 deletions
diff --git a/Horde_Editor-path.patch b/Horde_Editor-path.patch
new file mode 100644
index 0000000..ed77dab
--- /dev/null
+++ b/Horde_Editor-path.patch
@@ -0,0 +1,13 @@
+--- Horde_Editor-2.0.1/lib/Horde/Editor/Ckeditor.php.old 2013-01-12 09:31:49.000000000 +0100
++++ Horde_Editor-2.0.1/lib/Horde/Editor/Ckeditor.php 2013-01-12 09:32:25.000000000 +0100
+@@ -33,8 +33,8 @@
+ }
+
+ $ck_file = empty($params['basic'])
+- ? 'ckeditor.js'
+- : 'ckeditor_basic.js';
++ ? 'ckeditor/ckeditor.js'
++ : 'ckeditor/ckeditor_basic.js';
+
+ if (isset($params['config'])) {
+ if (is_array($params['config'])) {
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Editor.spec b/php-horde-Horde-Editor.spec
new file mode 100644
index 0000000..d5e8b78
--- /dev/null
+++ b/php-horde-Horde-Editor.spec
@@ -0,0 +1,112 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Editor
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Editor
+Version: 2.0.1
+Release: 1%{?dist}
+Summary: Horde Editor API
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+# Change path of ckeditor to a subdir of /js
+# See http://bugs.horde.org/ticket/11950
+Patch0: %{pear_name}-path.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-common >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+BuildRequires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: ckeditor
+Requires: php-common >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0
+Requires: php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Browser) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Serialize) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Serialize) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+The Horde_Editor package provides an API to generate the code necessary for
+embedding javascript RTE editors in a web page.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+# Don't install ckeditor, use system one
+# Remove md5sum for patched file
+%patch0 -p1 -b .path
+sed -e '/name="js/d' \
+ -e '/Ckeditor.php/s/md5sum=.*name/name/' \
+ ../package.xml >%{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+# Create a symlink to system ckeditor
+# Can't be relative as hordedir defined somewhere else
+# I will prefer an Alias, but https://bugzilla.redhat.com/894567
+mkdir -p %{buildroot}%{pear_hordedir}/js
+ln -s %{_datadir}/ckeditor %{buildroot}%{pear_hordedir}/js/ckeditor
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Editor
+%{pear_phpdir}/Horde/Editor.php
+%dir %{pear_hordedir}/js
+%{pear_hordedir}/js/ckeditor
+
+
+%changelog
+* Sat Jan 12 2013 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- Initial package