summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-08-01 10:27:47 +0200
committerRemi Collet <fedora@famillecollet.com>2012-08-01 10:27:47 +0200
commit0d3aa979178e9599c60e343fb4542331dc3a78f5 (patch)
treee246010fb1537af1b577d580f9f668c187993fb4
php-horde-Horde-Date: import from rawhide
-rw-r--r--php-horde-Horde-Date.spec99
1 files changed, 99 insertions, 0 deletions
diff --git a/php-horde-Horde-Date.spec b/php-horde-Horde-Date.spec
new file mode 100644
index 0000000..0641bd0
--- /dev/null
+++ b/php-horde-Horde-Date.spec
@@ -0,0 +1,99 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Date
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Date
+Version: 1.0.11
+Release: 1%{?dist}
+Summary: Horde Date package
+
+Group: Development/Libraries
+License: LGPLv2+
+URL: http://pear.horde.org
+Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+
+BuildRequires: php-pear >= 1:1.4.9-1.2
+BuildRequires: php-channel(%{pear_channel})
+BuildRequires: gettext
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(%{pear_channel}/Horde_Nls) < 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) < 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 2.0.0
+Requires: php-common >= 5.2.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+Package for creating and manipulating dates.
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+
+# Don't install .po and .pot files
+# Remove checksum for .mo, as we regenerate them
+sed -e '/%{pear_name}.po/d' \
+ -e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+
+# Regenerate the locales
+for po in $(find locale -name \*.po)
+do
+ msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
+done
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+%find_lang %{pear_name}
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Date
+%{pear_phpdir}/Horde/Date.php
+%{pear_testdir}/%{pear_name}
+# own locales (non standard) directories, .mo own by find_lang
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+
+
+%changelog
+* Thu Jul 12 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.11-1
+- Update to 1.0.11, fix packaging issues
+
+* Thu Jun 14 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.10-1
+- Update to 1.0.10, fix packaging issues
+
+* Sat Jan 28 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.9-1
+- Initial package