summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Date-Parser.spec18
1 files changed, 15 insertions, 3 deletions
diff --git a/php-horde-Horde-Date-Parser.spec b/php-horde-Horde-Date-Parser.spec
index 24e7e02..00842f5 100644
--- a/php-horde-Horde-Date-Parser.spec
+++ b/php-horde-Horde-Date-Parser.spec
@@ -78,11 +78,23 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-%{_bindir}/phpunit .
-if which php70; then
- php70 %{_bindir}/phpunit .
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit . || ret=1
+ run=1
fi
+if which php71; then
+ php71 %{_bindir}/phpunit . || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --verbose .
+# remirepo:2
+fi
+exit $ret
%post