summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Data.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Data.spec')
-rw-r--r--php-horde-Horde-Data.spec43
1 files changed, 32 insertions, 11 deletions
diff --git a/php-horde-Horde-Data.spec b/php-horde-Horde-Data.spec
index 10d3449..38677e7 100644
--- a/php-horde-Horde-Data.spec
+++ b/php-horde-Horde-Data.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Data
#
-# Copyright (c) 2012-2017 Nick Bebout, Remi Collet
+# Copyright (c) 2012-2020 Nick Bebout, Remi Collet
#
# License: MIT
# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
@@ -12,23 +12,25 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Data
-Version: 2.1.4
+Version: 2.1.5
Release: 1%{?dist}
Summary: Horde Data API
-Group: Development/Libraries
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
# To run unit tests
-BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-pear(%{pear_channel}/Horde_Test) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Test) < 3)
+%else
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%endif
Requires(post): %{__pear}
Requires(postun): %{__pear}
@@ -38,6 +40,15 @@ Requires: php-pcre
Requires: php-spl
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Browser) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Exception) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Icalendar) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Icalendar) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Mail) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Mime) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Mime) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0 with php-pear(%{pear_channel}/Horde_Translation) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+%else
Requires: php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Browser) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
@@ -52,6 +63,7 @@ Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
Requires: php-pear(%{pear_channel}/Horde_Translation) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+%endif
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
Provides: php-composer(horde/horde-data) = %{version}
@@ -108,11 +120,14 @@ done | tee ../%{pear_name}.lang
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-%{_bindir}/phpunit .
-if which php70; then
- php70 %{_bindir}/phpunit .
-fi
+ret=0
+for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
+ fi
+done
+exit $ret
%post
@@ -127,17 +142,23 @@ fi
%files -f %{pear_name}.lang
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Data
%{pear_phpdir}/Horde/Data.php
-%{pear_testdir}/%{pear_name}
+%doc %{pear_testdir}/%{pear_name}
%dir %{pear_datadir}/%{pear_name}
%dir %{pear_datadir}/%{pear_name}/locale
%changelog
+* Wed Feb 5 2020 Remi Collet <remi@remirepo.net> - 2.1.5-1
+- update to 2.1.5
+- use range dependencies
+
+* Thu Oct 12 2017 Remi Collet <remi@remirepo.net> - 2.1.4-1
+- add upstream patch for PHP 7.2, FTBFS from Koschei
+
* Tue Feb 02 2016 Remi Collet <remi@fedoraproject.org> - 2.1.4-1
- Update to 2.1.4
- PHP 7 compatible version