summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Data.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Data.spec')
-rw-r--r--php-horde-Horde-Data.spec35
1 files changed, 24 insertions, 11 deletions
diff --git a/php-horde-Horde-Data.spec b/php-horde-Horde-Data.spec
index bb73b54..38677e7 100644
--- a/php-horde-Horde-Data.spec
+++ b/php-horde-Horde-Data.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Data
#
-# Copyright (c) 2012-2017 Nick Bebout, Remi Collet
+# Copyright (c) 2012-2020 Nick Bebout, Remi Collet
#
# License: MIT
# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
@@ -12,24 +12,25 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Data
-Version: 2.1.4
-Release: 4%{?dist}
+Version: 2.1.5
+Release: 1%{?dist}
Summary: Horde Data API
-Group: Development/Libraries
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: https://github.com/horde/Data/commit/78ad0c2390176cdde7260a271bc6ddd86f4c9c0e.patch
-
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
# To run unit tests
-BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-pear(%{pear_channel}/Horde_Test) >= 2.1.0 with php-pear(%{pear_channel}/Horde_Test) < 3)
+%else
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%endif
Requires(post): %{__pear}
Requires(postun): %{__pear}
@@ -39,6 +40,15 @@ Requires: php-pcre
Requires: php-spl
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Browser) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Exception) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Icalendar) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Icalendar) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Mail) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Mail) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Mime) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Mime) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0 with php-pear(%{pear_channel}/Horde_Translation) < 3)
+Requires: (php-pear(%{pear_channel}/Horde_Util) >= 2.0.0 with php-pear(%{pear_channel}/Horde_Util) < 3)
+%else
Requires: php-pear(%{pear_channel}/Horde_Browser) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Browser) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
@@ -53,6 +63,7 @@ Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
Requires: php-pear(%{pear_channel}/Horde_Translation) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+%endif
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
Provides: php-composer(horde/horde-data) = %{version}
@@ -70,13 +81,11 @@ A data import and export API, with backends for:
%prep
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1 -b .upstream
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
- -e '/Csv.php/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -113,9 +122,9 @@ done | tee ../%{pear_name}.lang
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose . || ret=1
+ $cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
fi
done
exit $ret
@@ -143,6 +152,10 @@ fi
%changelog
+* Wed Feb 5 2020 Remi Collet <remi@remirepo.net> - 2.1.5-1
+- update to 2.1.5
+- use range dependencies
+
* Thu Oct 12 2017 Remi Collet <remi@remirepo.net> - 2.1.4-1
- add upstream patch for PHP 7.2, FTBFS from Koschei