summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-03 14:21:51 +0200
committerRemi Collet <remi@remirepo.net>2017-05-03 14:21:51 +0200
commit50f538175ee5c99753ec6d46ff09a80c8cfb5fcc (patch)
treef8b1377f398f743ac891c86a0b789497723563c0
parent3beba0ff902d2e535bbf43a6e61ff57b61689671 (diff)
v2.7.7
-rw-r--r--php-horde-Horde-Crypt-pr220.patch24
-rw-r--r--php-horde-Horde-Crypt.spec33
2 files changed, 42 insertions, 15 deletions
diff --git a/php-horde-Horde-Crypt-pr220.patch b/php-horde-Horde-Crypt-pr220.patch
new file mode 100644
index 0000000..dbe6e5e
--- /dev/null
+++ b/php-horde-Horde-Crypt-pr220.patch
@@ -0,0 +1,24 @@
+From 6f16c25d4e3780469e86ca1b6c6f2d8ca47ee786 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 3 May 2017 14:14:19 +0200
+Subject: [PATCH] '--pinentry-mode loopback' was introduce in gnupg 2.1.12
+
+---
+ framework/Crypt/lib/Horde/Crypt/Pgp/Backend/Binary.php | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/framework/Crypt/lib/Horde/Crypt/Pgp/Backend/Binary.php b/framework/Crypt/lib/Horde/Crypt/Pgp/Backend/Binary.php
+index 73d6d40..71e765d 100644
+--- a/framework/Crypt/lib/Horde/Crypt/Pgp/Backend/Binary.php
++++ b/framework/Crypt/lib/Horde/Crypt/Pgp/Backend/Binary.php
+@@ -80,8 +80,8 @@ public function __construct($gnupg, $temp = null)
+
+ /* GnuPG 2 requires specifying the pinentry-mode. */
+ $result = $this->_callGpg(array('--version'), 'r');
+- if (preg_match('/gpg \(GnuPG\) (\d+)\.(\d+)\.(\d+)/', $result->stdout, $version) &&
+- $version[1] >= 2) {
++ if (preg_match('/gpg \(GnuPG\) (\d+\.\d+\.\d+)/', $result->stdout, $version) &&
++ version_compare($version[1], '2.1.12', 'ge') ) {
+ $this->_gnupg[] = '--pinentry-mode loopback';
+ file_put_contents(
+ $this->_tempdir . '/gpg-agent.conf',
diff --git a/php-horde-Horde-Crypt.spec b/php-horde-Horde-Crypt.spec
index daebc46..b301d14 100644
--- a/php-horde-Horde-Crypt.spec
+++ b/php-horde-Horde-Crypt.spec
@@ -12,7 +12,7 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Crypt
-Version: 2.7.6
+Version: 2.7.7
Release: 1%{?dist}
Summary: Horde Cryptography API
@@ -21,6 +21,9 @@ License: LGPLv2
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# https://github.com/horde/horde/pull/220
+Patch0: %{name}-pr220.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -72,11 +75,13 @@ systems.
%prep
%setup -q -c
cd %{pear_name}-%{version}
+%patch0 -p3 -b .pr220
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ -e '/Binary.php/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -113,22 +118,16 @@ done | tee ../%{pear_name}.lang
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
: Skip online test
rm PgpKeyserverTest.php
+%if 0%{?rhel}
+#rm -r Pgp*
+%endif
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit . || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit . || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose .
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit . --verbose || ret=1
+ fi
+done
exit $ret
@@ -154,6 +153,10 @@ fi
%changelog
+* Wed May 3 2017 Remi Collet <remi@remirepo.net> - 2.7.7-1
+- Update to 2.7.7
+- open https://github.com/horde/horde/pull/220 - fix for gnupg 2.0
+
* Tue Apr 4 2017 Remi Collet <remi@remirepo.net> - 2.7.6-1
- Update to 2.7.6