summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-19 22:03:49 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-19 22:03:49 +0100
commitfb5d0a04dc3438995b282fd9b84149257c37fc4e (patch)
tree0fea0a344dabf25b6d1e9ce2a3ef20dc78bb0e11
php-horde-Horde-Crypt-Blowfish: new package
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Crypt-Blowfish.spec98
2 files changed, 102 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Crypt-Blowfish.spec b/php-horde-Horde-Crypt-Blowfish.spec
new file mode 100644
index 0000000..5f70a31
--- /dev/null
+++ b/php-horde-Horde-Crypt-Blowfish.spec
@@ -0,0 +1,98 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Crypt_Blowfish
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Crypt-Blowfish
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Blowfish Encryption Library
+
+Group: Development/Libraries
+License: LGPLv2+
+URL: http://pear.horde.org
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+Requires: php-hash
+BuildRequires: php-mcrypt
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-hash
+Requires: php-mcrypt
+Requires: php-openssl
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Provides blowfish encryption/decryption for PHP string data.
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+cp ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit\
+ -d include_path=%{buildroot}%{pear_phpdir}:.:%{pear_phpdir} \
+ -d date.timezone=UTC \
+ .
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Crypt/Blowfish
+%{pear_phpdir}/Horde/Crypt/Blowfish.php
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Mon Nov 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.0.0-1
+- Initial package