summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-01 13:13:20 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-01 13:13:20 +0100
commitfe8c89e13ffa9eb5a132e84bafc9a984044887b8 (patch)
tree501079538681edbc0e289003e4fe4a08b8d2b3c6
parent938f50cffc114ca4997766fc381fa41d42ad8a29 (diff)
php-horde-Horde-Constraint 2.0.0
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Constraint.spec43
2 files changed, 26 insertions, 21 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Constraint.spec b/php-horde-Horde-Constraint.spec
index 5ecf1b7..1669191 100644
--- a/php-horde-Horde-Constraint.spec
+++ b/php-horde-Horde-Constraint.spec
@@ -1,8 +1,10 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Constraint
+%global pear_name Horde_Constraint
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Constraint
-Version: 1.0.1
+Version: 2.0.0
Release: 2%{?dist}
Summary: Horde Constraint library
@@ -11,32 +13,27 @@ License: BSD
URL: http://pear.horde.org
Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
-BuildRequires: php-pear(PEAR) >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
-
-Requires: php-channel(pear.horde.org)
-Requires: php-common >= 5.2.0
-Requires: php-pear(PEAR) >= 1.7.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
%description
A programmatic way of building constraints that evaluate to true or false.
%prep
-%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
-
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
%build
@@ -46,14 +43,14 @@ cd %{pear_name}-%{version}
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -62,11 +59,12 @@ install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
%files
+%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Constraint
@@ -74,6 +72,9 @@ fi
%{pear_testdir}/Horde_Constraint
%changelog
+* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Tue Sep 18 2012 Nick Bebout <nb@fedoraproject.org> - 1.0.1-2
- Fix packaging issues