summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--2.patch54
-rw-r--r--php-horde-Horde-Compress.spec12
2 files changed, 64 insertions, 2 deletions
diff --git a/2.patch b/2.patch
new file mode 100644
index 0000000..4cd0097
--- /dev/null
+++ b/2.patch
@@ -0,0 +1,54 @@
+From 8583ea9e308ddc03dacc53679b02ab6cdfe9dd0c Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 1 Oct 2019 14:20:46 +0200
+Subject: [PATCH] Fix curly braces is deprecated
+
+---
+ lib/Horde/Compress/Tnef/Rtf.php | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/lib/Horde/Compress/Tnef/Rtf.php b/lib/Horde/Compress/Tnef/Rtf.php
+index 3b62faf..36cf889 100644
+--- a/lib/Horde/Compress/Tnef/Rtf.php
++++ b/lib/Horde/Compress/Tnef/Rtf.php
+@@ -130,20 +130,20 @@ protected function _decompress()
+ $length_preload = strlen($preload);
+
+ for ($cnt = 0; $cnt < $length_preload; $cnt++) {
+- $uncomp .= $preload{$cnt};
++ $uncomp .= $preload[$cnt];
+ ++$out;
+ }
+
+ while ($out < ($this->_size + $length_preload)) {
+ if (($flag_count++ % 8) == 0) {
+- $flags = ord($this->_data{$in++});
++ $flags = ord($this->_data[$in++]);
+ } else {
+ $flags = $flags >> 1;
+ }
+
+ if (($flags & 1) != 0) {
+- $offset = ord($this->_data{$in++});
+- $length = ord($this->_data{$in++});
++ $offset = ord($this->_data[$in++]);
++ $length = ord($this->_data[$in++]);
+ $offset = ($offset << 4) | ($length >> 4);
+ $length = ($length & 0xF) + 2;
+ $offset = ((int)($out / 4096)) * 4096 + $offset;
+@@ -156,7 +156,7 @@ protected function _decompress()
+ ++$out;
+ }
+ } else {
+- $uncomp .= $this->_data{$in++};
++ $uncomp .= $this->_data[$in++];
+ ++$out;
+ }
+ }
+@@ -363,4 +363,4 @@ protected function _rtfIsPlain($s)
+ return true;
+ }
+
+-}
+\ No newline at end of file
++}
diff --git a/php-horde-Horde-Compress.spec b/php-horde-Horde-Compress.spec
index 57c2ee1..2b376ce 100644
--- a/php-horde-Horde-Compress.spec
+++ b/php-horde-Horde-Compress.spec
@@ -13,13 +13,15 @@
Name: php-horde-Horde-Compress
Version: 2.2.2
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Horde Compression API
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/horde/Compress/pull/2.patch
+
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
@@ -87,11 +89,13 @@ An API for various compression techniques.
%prep
%setup -q -c
cd %{pear_name}-%{version}
+%patch0 -p1
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ -e '/Rtf.php/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -128,7 +132,7 @@ done | tee ../%{pear_name}.lang
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
ret=0
-for cmd in php php56 php70 php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --bootstrap bootstrap.php --verbose . || ret=1
fi
@@ -157,6 +161,10 @@ fi
%changelog
+* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 2.2.2-3
+- add patch for PHP 7.4 from
+ https://github.com/horde/Compress/pull/2
+
* Mon Feb 11 2019 Remi Collet <remi@remirepo.net> - 2.2.2-1
- update to 2.2.2
- drop patch merged upstream