summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--2.patch54
-rw-r--r--php-horde-Horde-Compress.spec13
2 files changed, 6 insertions, 61 deletions
diff --git a/2.patch b/2.patch
deleted file mode 100644
index 4cd0097..0000000
--- a/2.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 8583ea9e308ddc03dacc53679b02ab6cdfe9dd0c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 1 Oct 2019 14:20:46 +0200
-Subject: [PATCH] Fix curly braces is deprecated
-
----
- lib/Horde/Compress/Tnef/Rtf.php | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/lib/Horde/Compress/Tnef/Rtf.php b/lib/Horde/Compress/Tnef/Rtf.php
-index 3b62faf..36cf889 100644
---- a/lib/Horde/Compress/Tnef/Rtf.php
-+++ b/lib/Horde/Compress/Tnef/Rtf.php
-@@ -130,20 +130,20 @@ protected function _decompress()
- $length_preload = strlen($preload);
-
- for ($cnt = 0; $cnt < $length_preload; $cnt++) {
-- $uncomp .= $preload{$cnt};
-+ $uncomp .= $preload[$cnt];
- ++$out;
- }
-
- while ($out < ($this->_size + $length_preload)) {
- if (($flag_count++ % 8) == 0) {
-- $flags = ord($this->_data{$in++});
-+ $flags = ord($this->_data[$in++]);
- } else {
- $flags = $flags >> 1;
- }
-
- if (($flags & 1) != 0) {
-- $offset = ord($this->_data{$in++});
-- $length = ord($this->_data{$in++});
-+ $offset = ord($this->_data[$in++]);
-+ $length = ord($this->_data[$in++]);
- $offset = ($offset << 4) | ($length >> 4);
- $length = ($length & 0xF) + 2;
- $offset = ((int)($out / 4096)) * 4096 + $offset;
-@@ -156,7 +156,7 @@ protected function _decompress()
- ++$out;
- }
- } else {
-- $uncomp .= $this->_data{$in++};
-+ $uncomp .= $this->_data[$in++];
- ++$out;
- }
- }
-@@ -363,4 +363,4 @@ protected function _rtfIsPlain($s)
- return true;
- }
-
--}
-\ No newline at end of file
-+}
diff --git a/php-horde-Horde-Compress.spec b/php-horde-Horde-Compress.spec
index 2b376ce..03aab19 100644
--- a/php-horde-Horde-Compress.spec
+++ b/php-horde-Horde-Compress.spec
@@ -12,16 +12,14 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Compress
-Version: 2.2.2
-Release: 3%{?dist}
+Version: 2.2.3
+Release: 1%{?dist}
Summary: Horde Compression API
License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/horde/Compress/pull/2.patch
-
BuildArch: noarch
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
@@ -89,13 +87,10 @@ An API for various compression techniques.
%prep
%setup -q -c
cd %{pear_name}-%{version}
-%patch0 -p1
-
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
- -e '/Rtf.php/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -161,6 +156,10 @@ fi
%changelog
+* Mon Nov 4 2019 Remi Collet <remi@remirepo.net> - 2.2.3-1
+- update to 2.2.3
+- drop patch merged upstream
+
* Tue Oct 1 2019 Remi Collet <remi@remirepo.net> - 2.2.2-3
- add patch for PHP 7.4 from
https://github.com/horde/Compress/pull/2