summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-06 13:17:23 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-06 13:17:23 +0100
commit45d27526e712828e7ef60c076818f8c6990ba5db (patch)
tree1438d1c585f0818ba115dce70d4b068c084fb707
php-horde-Horde-Compress-Fast: new package (for Horde_Cache)
-rw-r--r--Makefile4
-rw-r--r--php-horde-Horde-Compress-Fast.spec102
2 files changed, 106 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-Horde-Compress-Fast.spec b/php-horde-Horde-Compress-Fast.spec
new file mode 100644
index 0000000..43944cf
--- /dev/null
+++ b/php-horde-Horde-Compress-Fast.spec
@@ -0,0 +1,102 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Horde_Compress_Fast
+%global pear_channel pear.horde.org
+
+Name: php-horde-Horde-Compress-Fast
+Version: 1.0.1
+Release: 1%{?dist}
+Summary: Fast Compression Library
+
+Group: Development/Libraries
+License: LGPLv2
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php(language) >= 5.3.0
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-channel(%{pear_channel})
+# Optional
+Requires: php-pecl(LZF)
+# TODO horde_lz4
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+Provides compression suitable for packing strings on-the-fly in PHP code
+(as opposed to more resource-intensive compression algorithms such as
+DEFLATE).
+
+
+%prep
+%setup -q -c
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%check
+src=$(pwd)/%{pear_name}-%{version}
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
+phpunit \
+ -d include_path=$src/lib:.:%{pear_phpdir} \
+ -d date.timezone=UTC \
+ .
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Horde/Compress
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Wed Mar 06 2013 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- New Package