summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Cli.spec47
1 files changed, 25 insertions, 22 deletions
diff --git a/php-horde-Horde-Cli.spec b/php-horde-Horde-Cli.spec
index 61b451a..190c385 100644
--- a/php-horde-Horde-Cli.spec
+++ b/php-horde-Horde-Cli.spec
@@ -1,9 +1,11 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Cli
+%global pear_name Horde_Cli
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Cli
-Version: 1.0.4
-Release: 2%{?dist}
+Version: 2.0.0
+Release: 1%{?dist}
Summary: Horde Command Line Interface API
Group: Development/Libraries
@@ -15,30 +17,28 @@ Source1: find-lang.sh
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear >= 1.7.0
-BuildRequires: php-channel(pear.horde.org)
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Support) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Translation) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Requires: php-channel(pear.horde.org)
+Requires: php-pear(%{pear_channel}/Horde_Support) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Support) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Translation) >= 3.0.0
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
Requires: php-pcre php-session
-Requires: php-common >= 5.2.0
-Provides: php-pear(pear.horde.org/%{pear_name}) = %{version}
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
%description
Horde_Cli:: API for basic command-line functionality/checks
%prep
-%setup -q -c
-
-# Create a "localized" php.ini to avoid build warning
-cp /etc/php.ini .
-echo "date.timezone=UTC" >>php.ini
+%setup -q -c -T
+tar xif %{SOURCE0}
cd %{pear_name}-%{version}
@@ -59,18 +59,18 @@ done
%install
cd %{pear_name}-%{version}
-PHPRC=../php.ini %{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+PHPRC=../php.ini %{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%if 0%{?fedora} > 13 || 0%{?rhel} > 6
%find_lang %{pear_name}
%else
-sh %{SOURCE1} $RPM_BUILD_ROOT %{pear_name}
+sh %{SOURCE1} %{buildroot} %{pear_name}
%endif
%post
@@ -80,7 +80,7 @@ sh %{SOURCE1} $RPM_BUILD_ROOT %{pear_name}
%postun
if [ $1 -eq 0 ] ; then
%{__pear} uninstall --nodeps --ignore-errors --register-only \
- pear.horde.org/%{pear_name} >/dev/null || :
+ %{pear_channel}/%{pear_name} >/dev/null || :
fi
%files -f %{pear_name}-%{version}/%{pear_name}.lang
@@ -96,6 +96,9 @@ fi
%dir %{pear_datadir}/Horde_Cli/locale/*/LC_MESSAGES
%changelog
+* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Thu Sep 20 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.0.4-2
- backport for remi repo