summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Cache.spec38
1 files changed, 16 insertions, 22 deletions
diff --git a/php-horde-Horde-Cache.spec b/php-horde-Horde-Cache.spec
index e126ef3..8e11210 100644
--- a/php-horde-Horde-Cache.spec
+++ b/php-horde-Horde-Cache.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-horde-Horde-Cache
#
-# Copyright (c) 2012-2017 Nick Bebout, Remi Collet
+# Copyright (c) 2012-2019 Nick Bebout, Remi Collet
#
# License: MIT
# https://fedoraproject.org/wiki/Licensing:MIT#Modern_Style_with_sublicense
@@ -13,7 +13,7 @@
Name: php-horde-Horde-Cache
Version: 2.5.5
-Release: 1%{?dist}
+Release: 5%{?dist}
Summary: Horde Caching API
Group: Development/Libraries
@@ -21,7 +21,6 @@ License: LGPLv2
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
@@ -44,12 +43,14 @@ Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
# From package.xml, optional
-Requires: php-pear(%{pear_channel}/Horde_HashTable) >= 1.0.0
-Requires: php-pear(%{pear_channel}/Horde_HashTable) < 2.0.0
-%if 0%{?fedora} > 21
+%if 0%{?fedora} > 21 || 0%{?rhel} >= 8
+Recommends: php-pear(%{pear_channel}/Horde_HashTable) >= 1.0.0
+Recommends: php-pear(%{pear_channel}/Horde_HashTable) < 2.0.0
Suggests: php-pear(%{pear_channel}/Horde_Mongo) >= 1.0.0
Suggests: php-pear(%{pear_channel}/Horde_Mongo) < 2.0.0
%else
+Requires: php-pear(%{pear_channel}/Horde_HashTable) >= 1.0.0
+Requires: php-pear(%{pear_channel}/Horde_HashTable) < 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Mongo) >= 1.0.0
Requires: php-pear(%{pear_channel}/Horde_Mongo) < 2.0.0
%endif
@@ -96,21 +97,12 @@ install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 -d apc.enable_cli=1 %{_bindir}/phpunit . || ret=1
- run=1
-fi
-if which php71; then
- php71 -d apc.enable_cli=1 %{_bindir}/phpunit . || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-php -d apc.enable_cli=1 %{_bindir}/phpunit --verbose .
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72 php73; do
+ if which $cmd; then
+ $cmd -d apc.enable_cli=1 %{_bindir}/phpunit . || ret=1
+ fi
+done
exit $ret
@@ -126,16 +118,18 @@ fi
%files
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Cache
%{pear_phpdir}/Horde/Cache.php
%{pear_datadir}/%{pear_name}
-%{pear_testdir}/%{pear_name}
+%doc %{pear_testdir}/%{pear_name}
%changelog
+* Fri Dec 4 2019 Remi Collet <remi@fedoraproject.org> - 2.5.5-5
+- cleanup for EL-8
+
* Mon Feb 27 2017 Remi Collet <remi@fedoraproject.org> - 2.5.5-1
- Update to 2.5.5