summaryrefslogtreecommitdiffstats
path: root/php-horde-Horde-Auth.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-horde-Horde-Auth.spec')
-rw-r--r--php-horde-Horde-Auth.spec74
1 files changed, 53 insertions, 21 deletions
diff --git a/php-horde-Horde-Auth.spec b/php-horde-Horde-Auth.spec
index 630d353..7de7b2d 100644
--- a/php-horde-Horde-Auth.spec
+++ b/php-horde-Horde-Auth.spec
@@ -1,34 +1,47 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
-%global pear_name Horde_Auth
+%global pear_name Horde_Auth
+%global pear_channel pear.horde.org
Name: php-horde-Horde-Auth
-Version: 1.4.9
+Version: 2.0.0
Release: 1%{?dist}
Summary: Horde Authentication API
Group: Development/Libraries
License: LGPLv2+
URL: http://pear.horde.org
-Source0: http://pear.horde.org/get/%{pear_name}-%{version}.tgz
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# /usr/lib/rpm/find-lang.sh from fedora 16
+Source1: find-lang.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
-BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-pear
+BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
+
Requires(post): %{__pear}
Requires(postun): %{__pear}
-Requires: php-pear(pear.horde.org/Horde_Exception) < 2.0.0
-Requires: php-pear(pear.horde.org/Horde_Util) < 2.0.0
-Requires: php-pear(PEAR) >= 1.7.0
-Provides: php-pear(pear.horde.org/Horde_Auth) = %{version}
-BuildRequires: php-channel(pear.horde.org)
-Requires: php-channel(pear.horde.org)
+Requires: php(language) >= 5.3.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Exception) >= 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Conflicts: php-pear(%{pear_channel}/Horde_Util) >= 3.0.0
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
%description
The Horde_Auth package provides a common interface into the various
backends for the Horde authentication system.
+
%prep
-%setup -q -c
+%setup -q -c -T
+tar xif %{SOURCE0}
+
cd %{pear_name}-%{version}
# Don't install .po and .pot files
@@ -37,6 +50,7 @@ sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
+
%build
cd %{pear_name}-%{version}
@@ -46,17 +60,29 @@ do
msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
done
+
%install
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+%if 0%{?fedora} > 13
%find_lang %{pear_name}
+%else
+sh %{SOURCE1} %{buildroot} %{pear_name}
+%endif
+
+
+%check
+cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:)
+# need Horde_Db phpunit AllTests.php
+
%post
%{__pear} install --nodeps --soft --force --register-only \
@@ -68,20 +94,26 @@ if [ $1 -eq 0 ] ; then
pear.horde.org/%{pear_name} >/dev/null || :
fi
+
%files -f %{pear_name}-%{version}/%{pear_name}.lang
+%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Auth
%{pear_phpdir}/Horde/Auth.php
-%{pear_testdir}/Horde_Auth
+%{pear_testdir}/%{pear_name}
# own locales (non standard) directories, .mo own by find_lang
-%dir %{pear_datadir}/Horde_Auth
-%dir %{pear_datadir}/Horde_Auth/locale
-%dir %{pear_datadir}/Horde_Auth/locale/*
-%dir %{pear_datadir}/Horde_Auth/locale/*/LC_MESSAGES
-%{pear_datadir}/Horde_Auth/migration/1_horde_auth_base_tables.php
+%dir %{pear_datadir}/%{pear_name}
+%dir %{pear_datadir}/%{pear_name}/locale
+%dir %{pear_datadir}/%{pear_name}/locale/*
+%dir %{pear_datadir}/%{pear_name}/locale/*/LC_MESSAGES
+%{pear_datadir}/%{pear_name}/migration
+
%changelog
+* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.0.0-1
+- Update to 2.0.0 for remi repo
+
* Thu Jun 21 2012 Nick Bebout <nb@fedoraproject.org> - 1.4.9-1
- Upgrade to 1.4.9