summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-horde-Horde-Auth.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/php-horde-Horde-Auth.spec b/php-horde-Horde-Auth.spec
index aab1a04..e2d2f3f 100644
--- a/php-horde-Horde-Auth.spec
+++ b/php-horde-Horde-Auth.spec
@@ -122,7 +122,10 @@ cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:)
ret=0
for cmd in php php56 php70 php71 php72; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose . || ret=1
+ if $cmd -r 'exit(function_exists("hex2bin") ? 0 : 1);'
+ then $cmd %{_bindir}/phpunit --verbose . || ret=1
+ else : test ignored
+ fi
fi
done
exit $ret