summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-01-09 10:26:50 +0100
committerRemi Collet <fedora@famillecollet.com>2015-01-09 10:26:50 +0100
commit87c65bb9569f00977a9edd3340b6ace306e23c28 (patch)
tree7c8fb3fe5e673bb41d2a3668b597dc57d5ee4b07
parent7d7a7abc5c5799264e98ee9dcf0a2ba55e24d7f0 (diff)
php-horde-Horde-Auth: add upstream patch for blowfish test
-rw-r--r--Horde_Auth-upstream.patch11
-rw-r--r--php-horde-Horde-Auth.spec10
2 files changed, 20 insertions, 1 deletions
diff --git a/Horde_Auth-upstream.patch b/Horde_Auth-upstream.patch
new file mode 100644
index 0000000..8cd825d
--- /dev/null
+++ b/Horde_Auth-upstream.patch
@@ -0,0 +1,11 @@
+--- test/Horde/Auth/TestCase.php 2015-01-08 17:43:19.000000000 +0100
++++ test/Horde/Auth/TestCase.php 2015-01-09 10:22:51.375634006 +0100
+@@ -21,7 +21,7 @@
+ return array(
+ array('aprmd5', '$apr1$11CBbKXP$AvvMGBjr81bC/NSMZIxrG.', '11CBbKXP'),
+ array('crypt', '8e3IWstJmsmxs', '8e'),
+- array('crypt-blowfish', '*0OayF9ttbxIs', '*0OayF9ttbxIs'),
++ array('crypt-blowfish', '$2lXRrxYRR396', '$2lXRrxYRR396'),
+ array('crypt-des', '45MibW6/G3XEY', '45'),
+ array('crypt-md5', '$1$537a3a0e$CWyLVJdQKfxbKPBv/Efzm0', '$1$537a3a0e$'),
+ array('md5-base64', 'OFj2IjCsPJFfMAxmQxLGPw==', ''),
diff --git a/php-horde-Horde-Auth.spec b/php-horde-Horde-Auth.spec
index 02019d8..81714ea 100644
--- a/php-horde-Horde-Auth.spec
+++ b/php-horde-Horde-Auth.spec
@@ -13,7 +13,7 @@
Name: php-horde-Horde-Auth
Version: 2.1.6
-Release: 1%{?dist}
+Release: 1%{?dist}.1
Summary: Horde Authentication API
Group: Development/Libraries
@@ -21,6 +21,9 @@ License: LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+# https://github.com/horde/horde/commit/00dc6c37f284d13c350af5a2e517047ac292e7e7
+Patch0: %{pear_name}-upstream.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
@@ -80,11 +83,13 @@ backends for the Horde authentication system.
%setup -q -c
cd %{pear_name}-%{version}
+%patch0 -p0 -b .upstream
# Don't install .po and .pot files
# Remove checksum for .mo, as we regenerate them
sed -e '/%{pear_name}.po/d' \
-e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ -e '/TestCase.php/s/md5sum=.*name=/name=/' \
../package.xml >%{name}.xml
touch -r ../package.xml %{name}.xml
@@ -146,6 +151,9 @@ fi
%changelog
+* Fri Jan 9 2015 Remi Collet <remi@fedoraproject.org> - 2.1.6-1.1
+- add upstream patch for blowfish test
+
* Thu Jan 08 2015 Remi Collet <remi@fedoraproject.org> - 2.1.6-1
- Update to 2.1.6
- add provides php-composer(horde/horde-auth)