summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-03 12:50:46 +0200
committerRemi Collet <remi@remirepo.net>2017-05-03 12:50:46 +0200
commit7a7ef079e74df2a8fcf44aa490095dac0a33432c (patch)
tree41d6f996befd73ed3cb7dff9a7243ba70bcaee7f
parent49c8fc8c10e1154471b16503a32998700677529d (diff)
v2.1.0
-rw-r--r--.gitignore7
-rw-r--r--php-horde-Horde-Argv.spec22
2 files changed, 22 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-horde-Horde-Argv.spec b/php-horde-Horde-Argv.spec
index 0582dfd..290c5f3 100644
--- a/php-horde-Horde-Argv.spec
+++ b/php-horde-Horde-Argv.spec
@@ -13,7 +13,7 @@
%global pear_channel pear.horde.org
Name: php-horde-Horde-Argv
-Version: 2.0.12
+Version: 2.1.0
Release: 1%{?dist}
Summary: Horde command-line argument parsing package
@@ -22,13 +22,13 @@ License: BSD and LGPLv2
URL: http://pear.horde.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
BuildRequires: php-pear(PEAR) >= 1.7.0
BuildRequires: php-channel(%{pear_channel})
BuildRequires: gettext
# To run unit tests
+BuildRequires: php-pear(%{pear_channel}/Horde_Cli) >= 2.2.0
BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
Requires(post): %{__pear}
@@ -38,6 +38,8 @@ Requires: php-reflection
Requires: php-spl
Requires: php-pear(PEAR) >= 1.7.0
Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/Horde_Cli) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Horde_Cli) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
Requires: php-pear(%{pear_channel}/Horde_Translation) >= 2.2.0
@@ -96,11 +98,14 @@ done | tee ../%{pear_name}.lang
%check
cd %{pear_name}-%{version}/test/$(echo %{pear_name} | sed -e s:_:/:g)
-%{_bindir}/phpunit .
-if which php70; then
- php70 %{_bindir}/phpunit .
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit . --verbose || ret=1
+ fi
+done
+exit $ret
%post
@@ -115,7 +120,6 @@ fi
%files -f %{pear_name}.lang
-%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Horde/Argv
@@ -125,6 +129,10 @@ fi
%changelog
+* Wed May 3 2017 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- Update to 2.1.0
+- add dependency on Horde_Cli
+
* Mon Feb 01 2016 Remi Collet <remi@fedoraproject.org> - 2.0.12-1
- Update to 2.0.12
- PHP 7 compatible version