summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--LICENSE29
-rw-r--r--Makefile4
-rw-r--r--php-hoa-stream-autoload.php17
-rw-r--r--php-hoa-stream.spec113
4 files changed, 163 insertions, 0 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..52862ba
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+ New BSD License
+
+
+
+Copyright © 2007-2016, Hoa community.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the Hoa nor the names of its contributors may be
+ used to endorse or promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS AND CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-hoa-stream-autoload.php b/php-hoa-stream-autoload.php
new file mode 100644
index 0000000..8e81f3e
--- /dev/null
+++ b/php-hoa-stream-autoload.php
@@ -0,0 +1,17 @@
+<?php
+/* Autoloader for hoa/stream and its dependencies */
+
+$vendor = '/usr/share/php';
+
+// Dependencies
+foreach ([
+ $vendor . '/Hoa/Consistency/autoload.php' => true,
+ $vendor . '/Hoa/Event/autoload.php' => true,
+ $vendor . '/Hoa/Exception/autoload.php' => true,
+ $vendor . '/Hoa/Protocol/autoload.php' => true,
+ ] as $dep => $mandatory) {
+ if ($mandatory || file_exists($dep)) require_once($dep);
+}
+
+$fedoraHoaLoader->addNamespace('Hoa\\Stream\\', __DIR__, true);
+
diff --git a/php-hoa-stream.spec b/php-hoa-stream.spec
new file mode 100644
index 0000000..3b675e6
--- /dev/null
+++ b/php-hoa-stream.spec
@@ -0,0 +1,113 @@
+# remirepo/fedora spec file for php-hoa-stream
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 1
+%global gh_commit c00b35078ef8c0881b7d2ed533de19fe0aaf9896
+#global gh_date 20150728
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner hoaproject
+%global gh_project Stream
+%global php_home %{_datadir}/php
+%global ns_vendor Hoa
+%global ns_project Stream
+%global pk_vendor hoa
+%global pk_project stream
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}
+Version: 1.16.01.14
+%global specrel 0
+Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Summary: The %{ns_vendor}\%{ns_project} library.
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source1: %{name}-autoload.php
+Source2: http://hoa-project.net/LICENSE
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php-composer(%{pk_vendor}/consistency) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/event) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/exception) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/protocol) >= 1.0
+%endif
+
+# from composer.json, "require": {
+# "hoa/consistency": "~1.0",
+# "hoa/event" : "~1.0",
+# "hoa/exception" : "~1.0",
+# "hoa/protocol" : "~1.0"
+Requires: php-composer(%{pk_vendor}/consistency) >= 1.0
+Requires: php-composer(%{pk_vendor}/consistency) < 2
+Requires: php-composer(%{pk_vendor}/event) >= 1.0
+Requires: php-composer(%{pk_vendor}/event) < 2
+Requires: php-composer(%{pk_vendor}/exception) >= 1.0
+Requires: php-composer(%{pk_vendor}/exception) < 2
+Requires: php-composer(%{pk_vendor}/protocol) >= 1.0
+Requires: php-composer(%{pk_vendor}/protocol) < 2
+# from phpcompatinfo report for version 1.16.01.14
+# none
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+The %{ns_vendor}\%{ns_project} library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+cp %{SOURCE1} autoload.php
+cp %{SOURCE2} LICENSE
+
+%build
+: Nothing
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+cp -pr *php %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/
+find . -mindepth 1 -maxdepth 1 -type d -print -exec \
+ cp -pr {} %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project} \; \
+
+
+%check
+%if %{with_tests}
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *md
+%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Wed Apr 6 2016 Remi Collet <remi@fedoraproject.org> - 1.16.01.14-0
+- initial package
+- bootstrap build
+