summaryrefslogtreecommitdiffstats
path: root/php-hoa-devtools.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-14 15:41:02 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-14 15:41:02 +0200
commit83aaaa50777e23764d2e0d4afb1a417cf583bfae (patch)
treebfb4ddfbc6a435fcb00ed7baba2c6b6522dee68b /php-hoa-devtools.spec
php-hoa-devtools: 1.16.01.15 (new package, wip)
Diffstat (limited to 'php-hoa-devtools.spec')
-rw-r--r--php-hoa-devtools.spec129
1 files changed, 129 insertions, 0 deletions
diff --git a/php-hoa-devtools.spec b/php-hoa-devtools.spec
new file mode 100644
index 0000000..4a819d1
--- /dev/null
+++ b/php-hoa-devtools.spec
@@ -0,0 +1,129 @@
+# remirepo/fedora spec file for php-hoa-devtools
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 1
+%global gh_commit e6e1210e6528b5f02bee9f78baa6d5aa0f7198c1
+#global gh_date 20150728
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner hoaproject
+%global gh_project Devtools
+%global php_home %{_datadir}/php
+%global ns_vendor Hoa
+%global ns_project Devtools
+%global pk_vendor hoa
+%global pk_project devtools
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}
+Version: 1.16.01.15
+%global specrel 0
+Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Summary: The %{ns_vendor}\%{ns_project} library.
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source1: %{name}-autoload.php
+Source2: http://hoa-project.net/LICENSE
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php-composer(%{pk_vendor}/cli) >= 2.0
+BuildRequires: php-composer(%{pk_vendor}/consistency) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/file) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/protocol) >= 1.0
+BuildRequires: php-composer(%{pk_vendor}/router) >= 3.0
+BuildRequires: php-composer(%{pk_vendor}/xyl) >= 1.0
+%endif
+
+# from composer.json, "require": {
+# "hoa/cli" : "~2.0",
+# "hoa/consistency": "~1.0",
+# "hoa/file" : "~1.0",
+# "hoa/protocol" : "~1.0",
+# "hoa/router" : "~3.0",
+# "hoa/xyl" : "~1.0"
+Requires: php-composer(%{pk_vendor}/cli) >= 2.0
+Requires: php-composer(%{pk_vendor}/cli) < 3
+Requires: php-composer(%{pk_vendor}/consistency) >= 1.0
+Requires: php-composer(%{pk_vendor}/consistency) < 2
+Requires: php-composer(%{pk_vendor}/file) >= 1.0
+Requires: php-composer(%{pk_vendor}/file) < 2
+Requires: php-composer(%{pk_vendor}/protocol) >= 1.0
+Requires: php-composer(%{pk_vendor}/protocol) < 2
+Requires: php-composer(%{pk_vendor}/router) >= 3.0
+Requires: php-composer(%{pk_vendor}/router) < 4
+Requires: php-composer(%{pk_vendor}/xyl) >= 1.0
+Requires: php-composer(%{pk_vendor}/xyl) < 2
+# from phpcompatinfo report for version 1.16.01.15
+Requires: php-reflection
+Requires: php-date
+Requires: php-json
+Requires: php-pcre
+Requires: php-tokenizer
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+The %{ns_vendor}\%{ns_project} library contains several development tools.
+This is for developers or maintainers. Sometimes it can be useful to users
+also, but in particular cases.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+cp %{SOURCE1} autoload.php
+cp %{SOURCE2} LICENSE
+
+
+%build
+: Nothing
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
+cp -pr *php %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/
+find . -mindepth 1 -maxdepth 1 -type d \! \( -name Test -o -name Documentation \) -print -exec \
+ cp -pr {} %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project} \;
+
+
+%check
+%if %{with_tests}
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *md
+%{php_home}/%{ns_vendor}/%{ns_project}
+
+
+%changelog
+* Thu Apr 14 2016 Remi Collet <remi@fedoraproject.org> - 1.16.01.15-0
+- initial package
+- bootstrap build
+