summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-23 09:13:54 +0100
committerRemi Collet <remi@remirepo.net>2021-03-23 09:13:54 +0100
commit83f88bf420f3ba06758617bd1f9b9524af72a029 (patch)
tree428325e74507380822f3c786703c5bb1693bdcf4
parentfec9ba49349aa7fb217de57ecb4fe5b9f061f6ec (diff)
update to 1.8.1
switch to phpunit9 add weak dependency on laminas/laminas-httphandlerrunner
-rw-r--r--composer.json6
-rw-r--r--php-guzzlehttp-psr7.spec24
2 files changed, 22 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 168a055..58dcb07 100644
--- a/composer.json
+++ b/composer.json
@@ -21,14 +21,14 @@
"ralouphie/getallheaders": "^2.0.5 || ^3.0.0"
},
"require-dev": {
- "phpunit/phpunit": "~4.8.36 || ^5.7.27 || ^6.5.8",
+ "phpunit/phpunit": "~4.8.36 || ^5.7.27 || ^6.5.14 || ^7.5.20 || ^8.5.8 || ^9.3.10",
"ext-zlib": "*"
},
"provide": {
"psr/http-message-implementation": "1.0"
},
"suggest": {
- "zendframework/zend-httphandlerrunner": "Emit PSR-7 responses"
+ "laminas/laminas-httphandlerrunner": "Emit PSR-7 responses"
},
"autoload": {
"psr-4": {
@@ -43,7 +43,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.6-dev"
+ "dev-master": "1.7-dev"
}
}
}
diff --git a/php-guzzlehttp-psr7.spec b/php-guzzlehttp-psr7.spec
index b5bc593..875a725 100644
--- a/php-guzzlehttp-psr7.spec
+++ b/php-guzzlehttp-psr7.spec
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name psr7
-%global github_version 1.6.1
-%global github_commit 239400de7a173fe9901b9ac7c06497751f00727a
+%global github_version 1.8.1
+%global github_commit 35ea11d335fd638b5882ff1725228b3d35496ab1
%global composer_vendor guzzlehttp
%global composer_project psr7
@@ -38,13 +38,18 @@
%endif
# PHPUnit
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
+%global phpunit_require phpunit9
+%global phpunit_exec phpunit9
+%else
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-%global phpunit_require phpunit6
-%global phpunit_exec phpunit6
+%global phpunit_require phpunit8
+%global phpunit_exec phpunit8
%else
%global phpunit_require php-composer(phpunit/phpunit)
%global phpunit_exec phpunit
%endif
+%endif
%{!?phpdir: %global phpdir %{_datadir}/php}
@@ -95,6 +100,7 @@ Requires: php(language) >= %{php_min_ver}
%if %{with_range_dependencies}
Requires: (php-composer(psr/http-message) >= %{psr_http_message_min_ver} with php-composer(psr/http-message) < %{psr_http_message_max_ver})
Requires: (php-composer(ralouphie/getallheaders) >= %{ralouphie_getallheaders_min_ver} with php-composer(ralouphie/getallheaders) < %{ralouphie_getallheaders_max_ver})
+Recommends: php-composer(laminas/laminas-httphandlerrunner)
%else
Requires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
Requires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
@@ -141,6 +147,9 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
'%{phpdir}/Psr/Http/Message/autoload.php',
'%{phpdir}/ralouphie-getallheaders/autoload.php',
]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{phpdir}/Laminas/HttpHandlerRunner/autoload.php',
+]);
AUTOLOAD
@@ -166,7 +175,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which %{phpunit_exec})
-for PHP_EXEC in "" %{?rhel:php55 php70 php71} php72 php73 php74; do
+for PHP_EXEC in "" %{?rhel:php55 php70 php71 php72} php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -188,6 +197,11 @@ exit $RETURN_CODE
%changelog
+* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 1.8.1-1
+- update to 1.8.1
+- switch to phpunit9
+- add weak dependency on laminas/laminas-httphandlerrunner
+
* Tue Dec 17 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.1-1
- Update to 1.6.1 (RHBZ #1727190)
- Conditionally use range dependencies