summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-02 07:33:02 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-02 07:33:02 +0200
commit42998f81c090fb2ecfc9198b1c4574257daae435 (patch)
treeda9feca199742e0abe611039e0305383f8a28ff1
parent539ca3906c4ee1ff00f12a089bbbc4e5734f8c6f (diff)
php-guzzlehttp-psr7: 1.3.1
-rw-r--r--composer.json35
-rw-r--r--php-guzzlehttp-psr7.spec22
2 files changed, 51 insertions, 6 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..fdfb97b
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "guzzlehttp/psr7",
+ "type": "library",
+ "description": "PSR-7 message implementation",
+ "keywords": ["message", "stream", "http", "uri"],
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Michael Dowling",
+ "email": "mtdowling@gmail.com",
+ "homepage": "https://github.com/mtdowling"
+ }
+ ],
+ "require": {
+ "php": ">=5.4.0",
+ "psr/http-message": "~1.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4.0"
+ },
+ "provide": {
+ "psr/http-message-implementation": "1.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "GuzzleHttp\\Psr7\\": "src/"
+ },
+ "files": ["src/functions_include.php"]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.4-dev"
+ }
+ }
+}
diff --git a/php-guzzlehttp-psr7.spec b/php-guzzlehttp-psr7.spec
index 54a8f6b..538eda2 100644
--- a/php-guzzlehttp-psr7.spec
+++ b/php-guzzlehttp-psr7.spec
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name psr7
-%global github_version 1.3.0
-%global github_commit 31382fef2889136415751badebbd1cb022a4ed72
+%global github_version 1.3.1
+%global github_commit 5c6447c9df362e8f8093bda8f5d8873fe5c7f65b
%global composer_vendor guzzlehttp
%global composer_project psr7
@@ -124,10 +124,17 @@ cp -rp src/* %{buildroot}%{phpdir}/GuzzleHttp/Psr7/
sed "s#require.*autoload.*#require '%{buildroot}%{phpdir}/GuzzleHttp/Psr7/autoload.php';#" \
-i tests/bootstrap.php
-%{_bindir}/phpunit --verbose
-
-if which php70; then
- php70 %{_bindir}/phpunit --verbose
+run=0
+if which php56; then
+ php56 %{_bindir}/phpunit --verbose
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --verbose
+ run=1
+fi
+if [ $run -eq 0 ]; then
+ %{_bindir}/phpunit --verbose
fi
%else
: Tests skipped
@@ -149,6 +156,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Jul 2 2016 Remi Collet <remi@remirepo.net> - 1.3.1-1
+- Updated to 1.3.1
+
* Sun May 29 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.0-1
- Updated to 1.3.0 (RHBZ #1326975)