summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json21
-rw-r--r--php-guzzlehttp-promises.spec9
2 files changed, 26 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index db44d9e..c959fb3 100644
--- a/composer.json
+++ b/composer.json
@@ -5,9 +5,24 @@
"license": "MIT",
"authors": [
{
+ "name": "Graham Campbell",
+ "email": "hello@gjcampbell.co.uk",
+ "homepage": "https://github.com/GrahamCampbell"
+ },
+ {
"name": "Michael Dowling",
"email": "mtdowling@gmail.com",
"homepage": "https://github.com/mtdowling"
+ },
+ {
+ "name": "Tobias Nyholm",
+ "email": "tobias.nyholm@gmail.com",
+ "homepage": "https://github.com/Nyholm"
+ },
+ {
+ "name": "Tobias Schultze",
+ "email": "webmaster@tubo-world.de",
+ "homepage": "https://github.com/Tobion"
}
],
"require": {
@@ -33,7 +48,11 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.4-dev"
+ "dev-master": "1.5-dev"
}
+ },
+ "config": {
+ "preferred-install": "dist",
+ "sort-packages": true
}
}
diff --git a/php-guzzlehttp-promises.spec b/php-guzzlehttp-promises.spec
index 3090e38..55dadee 100644
--- a/php-guzzlehttp-promises.spec
+++ b/php-guzzlehttp-promises.spec
@@ -14,8 +14,8 @@
%global github_owner guzzle
%global github_name promises
-%global github_version 1.4.1
-%global github_commit 8e7d04f1f6450fef59366c399cfad4b9383aa30d
+%global github_version 1.5.0
+%global github_commit 136a635e2b4a49b9d79e9c8fee267ffb257fdba0
%global composer_vendor guzzlehttp
%global composer_project promises
@@ -115,7 +115,7 @@ EOF
: Upstream tests with SCLs if available
SCL_RETURN_CODE=0
-for SCL in php php73 php74 php80; do
+for SCL in php php73 php74 php80 php81; do
if which $SCL; then
$SCL %{_bindir}/phpunit9 || SCL_RETURN_CODE=1
fi
@@ -141,6 +141,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Oct 21 2021 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
* Wed Mar 31 2021 Remi Collet <remi@remirepo.net> - 1.4.1-1
- update to 1.4.1
- switch to phpunit9