summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-guzzlehttp-guzzle6.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php-guzzlehttp-guzzle6.spec b/php-guzzlehttp-guzzle6.spec
index bcc25da..495c8f8 100644
--- a/php-guzzlehttp-guzzle6.spec
+++ b/php-guzzlehttp-guzzle6.spec
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name guzzle
-%global github_version 6.5.0
-%global github_commit dbc2bc3a293ed6b1ae08a3651e2bfd213d19b6a5
+%global github_version 6.5.2
+%global github_commit 43ece0e75098b7ecd8d13918293029e555a50f82
%global composer_vendor guzzlehttp
%global composer_project guzzle
@@ -82,7 +82,7 @@ BuildRequires: nodejs
BuildRequires: php-curl
BuildRequires: php-json
BuildRequires: phpunit7
-## phpcompatinfo (computed from version 6.5.0)
+## phpcompatinfo (computed from version 6.5.2)
BuildRequires: php-date
BuildRequires: php-filter
BuildRequires: php-intl
@@ -114,7 +114,7 @@ Requires: php-composer(guzzlehttp/psr7) >= %{psr7_min_ver}
Requires: php-composer(psr/log) < %{psr_log_max_ver}
Requires: php-composer(psr/log) >= %{psr_log_min_ver}
%endif
-# phpcompatinfo (computed from version 6.5.0)
+# phpcompatinfo (computed from version 6.5.2)
Requires: php-curl
Requires: php-date
Requires: php-filter
@@ -175,12 +175,10 @@ cp -pr src %{buildroot}%{phpdir}/GuzzleHttp6
%check
-: Library version value and autoloader check
+: Autoloader check
%{_bindir}/php -r '
require_once "%{buildroot}%{phpdir}/GuzzleHttp6/autoload.php";
- $version = \GuzzleHttp\ClientInterface::VERSION;
- echo "Version $version (expected %{version})\n";
- exit(version_compare("%{version}", "$version", "=") ? 0 : 1);
+ exit(interface_exists("\\GuzzleHttp\\ClientInterface") ? 0 : 1);
'
%if %{with_tests}
@@ -222,6 +220,12 @@ exit $RETURN_CODE
%changelog
+* Thu Dec 26 2019 Shawn Iwinski <shawn@iwin.ski> - 6.5.2-1
+- Update to 6.5.2 (RHBZ #1764727)
+- Remove version check and only do autoloader check b/c
+ `\GuzzleHttp\ClientInterface::VERSION` is
+ `@deprecated Will be removed in Guzzle 7.0.0`
+
* Tue Dec 17 2019 Shawn Iwinski <shawn@iwin.ski> - 6.5.0-1
- Update to 6.5.0 (RHBZ #1764727)
- Use PHPUnit 7