summaryrefslogtreecommitdiffstats
path: root/php-guzzlehttp-guzzle6.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-19 09:26:44 +0100
committerRemi Collet <remi@remirepo.net>2019-12-19 09:26:44 +0100
commiteb4305c2da5d0ffc8760ec5cafa682fdd1377805 (patch)
tree744a6d4535f6bfd030132acf81b573ab4de63625 /php-guzzlehttp-guzzle6.spec
parent2eeeac424fec5eca0629ea55f25c914dd52679a8 (diff)
v6.5.0 from Fedora
Diffstat (limited to 'php-guzzlehttp-guzzle6.spec')
-rw-r--r--php-guzzlehttp-guzzle6.spec53
1 files changed, 34 insertions, 19 deletions
diff --git a/php-guzzlehttp-guzzle6.spec b/php-guzzlehttp-guzzle6.spec
index 5a17680..bcc25da 100644
--- a/php-guzzlehttp-guzzle6.spec
+++ b/php-guzzlehttp-guzzle6.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-guzzlehttp-guzzle6
#
-# Copyright (c) 2015-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2015-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name guzzle
-%global github_version 6.3.3
-%global github_commit 407b0cb880ace85c9b63c5f9551db498cb2d50ba
+%global github_version 6.5.0
+%global github_commit dbc2bc3a293ed6b1ae08a3651e2bfd213d19b6a5
%global composer_vendor guzzlehttp
%global composer_project guzzle
@@ -23,26 +23,31 @@
# "guzzlehttp/promises": "^1.0"
%global promises_min_ver 1.0
%global promises_max_ver 2.0
-# "guzzlehttp/psr7": "^1.4"
-%global psr7_min_ver 1.4
+# "guzzlehttp/psr7": "^1.6.1"
+%global psr7_min_ver 1.6.1
%global psr7_max_ver 2.0
-# "psr/log": "^1.0"
-# NOTE: Min version not 1.0 because autoloader required
-%global psr_log_min_ver 1.0.1
+# "psr/log": "^1.1"
+%global psr_log_min_ver 1.1
%global psr_log_max_ver 2.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
+# Range dependencies supported?
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global with_range_dependencies 1
+%else
+%global with_range_dependencies 0
+%endif
+
%{!?phpdir: %global phpdir %{_datadir}/php}
%{!?testsdir: %global testsdir %{_datadir}/tests}
Name: php-%{composer_vendor}-%{composer_project}6
Version: %{github_version}
-Release: 6%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: PHP HTTP client library
-Group: Development/Libraries
License: MIT
URL: http://guzzlephp.org
@@ -56,8 +61,7 @@ BuildArch: noarch
BuildRequires: php-cli
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if %{with_range_dependencies}
BuildRequires: (php-composer(guzzlehttp/promises) >= %{promises_min_ver} with php-composer(guzzlehttp/promises) < %{promises_max_ver})
BuildRequires: (php-composer(guzzlehttp/psr7) >= %{psr7_min_ver} with php-composer(guzzlehttp/psr7) < %{psr7_max_ver})
BuildRequires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
@@ -74,12 +78,14 @@ BuildRequires: php-composer(fedora/autoloader)
# Tests
%if %{with_tests}
BuildRequires: nodejs
-## phpcompatinfo (computed from version 6.3.3)
+## composer.json
BuildRequires: php-curl
+BuildRequires: php-json
+BuildRequires: phpunit7
+## phpcompatinfo (computed from version 6.5.0)
BuildRequires: php-date
BuildRequires: php-filter
BuildRequires: php-intl
-BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -89,12 +95,17 @@ BuildRequires: php-zlib
Requires: ca-certificates
# composer.json
Requires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: php-json
+# composer.json: optional
+Requires: php-intl
+%if %{with_range_dependencies}
+# composer.json
Requires: (php-composer(guzzlehttp/promises) >= %{promises_min_ver} with php-composer(guzzlehttp/promises) < %{promises_max_ver})
Requires: (php-composer(guzzlehttp/psr7) >= %{psr7_min_ver} with php-composer(guzzlehttp/psr7) < %{psr7_max_ver})
# composer.json: optional
Requires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
%else
+# composer.json
Requires: php-composer(guzzlehttp/promises) < %{promises_max_ver}
Requires: php-composer(guzzlehttp/promises) >= %{promises_min_ver}
Requires: php-composer(guzzlehttp/psr7) < %{psr7_max_ver}
@@ -103,11 +114,10 @@ Requires: php-composer(guzzlehttp/psr7) >= %{psr7_min_ver}
Requires: php-composer(psr/log) < %{psr_log_max_ver}
Requires: php-composer(psr/log) >= %{psr_log_min_ver}
%endif
-# phpcompatinfo (computed from version 6.3.3)
+# phpcompatinfo (computed from version 6.5.0)
Requires: php-curl
Requires: php-date
Requires: php-filter
-Requires: php-json
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -179,6 +189,7 @@ mkdir vendor
cat <<'AUTOLOAD' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{phpdir}/GuzzleHttp6/autoload.php';
+
\Fedora\Autoloader\Autoload::addPsr4('GuzzleHttp\\Tests\\', __DIR__.'/tests');
AUTOLOAD
@@ -188,8 +199,8 @@ sed 's/function testAddsCookiesWithEmptyPathFromResponse/function SKIP_testAddsC
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" php70 php71 php72 php73; do
+PHPUNIT=$(which phpunit7)
+for PHP_EXEC in "" php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT \
--filter '^((?!(testDescribesType|testInvokesOnStatsOnError)).)*$' \
@@ -211,6 +222,10 @@ exit $RETURN_CODE
%changelog
+* Tue Dec 17 2019 Shawn Iwinski <shawn@iwin.ski> - 6.5.0-1
+- Update to 6.5.0 (RHBZ #1764727)
+- Use PHPUnit 7
+
* Sun Sep 08 2019 Shawn Iwinski <shawn@iwin.ski> - 6.3.3-6
- Fix FTBFS (RHBZ #1736433)