summaryrefslogtreecommitdiffstats
path: root/php-guzzlehttp-guzzle6.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-05-30 09:45:29 +0200
committerRemi Collet <remi@php.net>2022-05-30 09:45:29 +0200
commit2f7681f803bdb090e4931fa792774170f2f4ae60 (patch)
tree040a624c78fadff07d1b1a81930d5f25eeec644e /php-guzzlehttp-guzzle6.spec
parent47e46366814ce343fc6e03de503dd6666cf50ffd (diff)
update to 6.5.6
Diffstat (limited to 'php-guzzlehttp-guzzle6.spec')
-rw-r--r--php-guzzlehttp-guzzle6.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/php-guzzlehttp-guzzle6.spec b/php-guzzlehttp-guzzle6.spec
index 07e690c..70d5851 100644
--- a/php-guzzlehttp-guzzle6.spec
+++ b/php-guzzlehttp-guzzle6.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-guzzlehttp-guzzle6
#
-# Copyright (c) 2015-2019 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2015-2022 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name guzzle
-%global github_version 6.5.5
-%global github_commit 9d4290de1cfd701f38099ef7e183b64b4b7b0c5e
+%global github_version 6.5.6
+%global github_commit f092dd734083473658de3ee4bef093ed77d2689c
%global composer_vendor guzzlehttp
%global composer_project guzzle
@@ -195,12 +195,13 @@ AUTOLOAD
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit7)
-for PHP_EXEC in php php73 php74 php80; do
+for PHP_EXEC in php php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- FILTER="testDescribesType|testInvokesOnStatsOnError|testAddsCookiesWithEmptyPathFromResponse|testCreatesExceptionWithoutPrintableBody"
VER=$($PHP_EXEC -r 'echo PHP_VERSION_ID;')
+ FILTER="testDescribesType|testInvokesOnStatsOnError|testAddsCookiesWithEmptyPathFromResponse|testCreatesExceptionWithoutPrintableBody"
if [ $VER -ge 80000 ]; then
+ # CurlHandle Object instead of resource
FILTER="$FILTER|testEmitsProgressToFunction|testCreatesCurlHandle"
fi
@@ -224,6 +225,9 @@ exit $RETURN_CODE
%changelog
+* Mon May 30 2022 Remi Collet <remi@remirepo.net> - 6.5.6-1
+- update to 6.5.6
+
* Thu Apr 1 2021 Remi Collet <remi@remirepo.net> - 6.5.5-1
- update to 6.5.5