summaryrefslogtreecommitdiffstats
path: root/php-guzzlehttp-guzzle6.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-09 08:46:19 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-09 08:46:19 +0200
commit1fe0c44341c66bf2e4994d00c85d404818c4138f (patch)
tree083b89121d9c65a36ff3cb769d3bf87d590ecb79 /php-guzzlehttp-guzzle6.spec
parent652a577a637ce70a4bcb435a8fc6d55c05ceb21b (diff)
php-guzzlehttp-guzzle6: sync with fedora
Diffstat (limited to 'php-guzzlehttp-guzzle6.spec')
-rw-r--r--php-guzzlehttp-guzzle6.spec24
1 files changed, 20 insertions, 4 deletions
diff --git a/php-guzzlehttp-guzzle6.spec b/php-guzzlehttp-guzzle6.spec
index b509696..57726c1 100644
--- a/php-guzzlehttp-guzzle6.spec
+++ b/php-guzzlehttp-guzzle6.spec
@@ -44,7 +44,7 @@
Name: php-%{composer_vendor}-%{composer_project}6
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 2%{?github_release}%{?dist}
Summary: PHP HTTP client library
Group: Development/Libraries
@@ -146,7 +146,7 @@ if (!isset($fedoraPsr4ClassLoader) || !($fedoraPsr4ClassLoader instanceof \Symfo
}
$fedoraPsr4ClassLoader = new \Symfony\Component\ClassLoader\Psr4ClassLoader();
- $fedoraPsr4ClassLoader->register();
+ $fedoraPsr4ClassLoader->register(true);
}
$fedoraPsr4ClassLoader->addPrefix('GuzzleHttp\\', __DIR__);
@@ -174,11 +174,22 @@ require_once '%{buildroot}%{phpdir}/GuzzleHttp6/autoload.php';
$fedoraPsr4ClassLoader->addPrefix('GuzzleHttp\\Tests\\', __DIR__.'/tests');
AUTOLOAD
-%{_bindir}/phpunit --verbose
+ret=0
+run=0
if which php70; then
- php70 %{_bindir}/phpunit --verbose
+ php70 %{_bindir}/phpunit --verbose || ret=1
+ run=1
fi
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+ %{_bindir}/phpunit --verbose || ret=1
+fi
+
+exit $ret
%else
: Tests skipped
%endif
@@ -198,6 +209,11 @@ rm -rf %{buildroot}
%changelog
+* Fri Apr 08 2016 Shawn Iwinski <shawn@iwin.ski> - 6.2.0-2
+- Prepend PSR-4 autoloader (fixes dual-install issue with
+ php-guzzlehttp-guzzle when other packages register PSR-0
+ autoloader first usually with include path failover)
+
* Sun Mar 27 2016 Shawn Iwinski <shawn@iwin.ski> - 6.2.0-1
- Updated to 6.2.0 (RHBZ #1319960)