summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-01 10:04:37 +0200
committerRemi Collet <remi@remirepo.net>2021-04-01 10:04:37 +0200
commit47e46366814ce343fc6e03de503dd6666cf50ffd (patch)
treeb4be67663e3056f3adab59da5d10f88b1fa1de78
parent2f18e64981441cd0bcde35520525ce4d56a37b08 (diff)
update to 6.5.5
-rw-r--r--composer.json4
-rw-r--r--php-guzzlehttp-guzzle6.spec25
2 files changed, 18 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index bbf0ff2..c01864f 100644
--- a/composer.json
+++ b/composer.json
@@ -23,6 +23,7 @@
"require": {
"php": ">=5.5",
"ext-json": "*",
+ "symfony/polyfill-intl-idn": "^1.17.0",
"guzzlehttp/promises": "^1.0",
"guzzlehttp/psr7": "^1.6.1"
},
@@ -32,8 +33,7 @@
"psr/log": "^1.1"
},
"suggest": {
- "psr/log": "Required for using the Log middleware",
- "ext-intl": "Required for Internationalized Domain Name (IDN) support"
+ "psr/log": "Required for using the Log middleware"
},
"config": {
"sort-packages": true
diff --git a/php-guzzlehttp-guzzle6.spec b/php-guzzlehttp-guzzle6.spec
index 495c8f8..07e690c 100644
--- a/php-guzzlehttp-guzzle6.spec
+++ b/php-guzzlehttp-guzzle6.spec
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name guzzle
-%global github_version 6.5.2
-%global github_commit 43ece0e75098b7ecd8d13918293029e555a50f82
+%global github_version 6.5.5
+%global github_commit 9d4290de1cfd701f38099ef7e183b64b4b7b0c5e
%global composer_vendor guzzlehttp
%global composer_project guzzle
@@ -85,11 +85,12 @@ BuildRequires: phpunit7
## phpcompatinfo (computed from version 6.5.2)
BuildRequires: php-date
BuildRequires: php-filter
-BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
BuildRequires: php-zlib
+# to avoid symfony/polyfill-intl-idn
+BuildRequires: php-intl
%endif
Requires: ca-certificates
@@ -191,17 +192,20 @@ require_once '%{buildroot}%{phpdir}/GuzzleHttp6/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('GuzzleHttp\\Tests\\', __DIR__.'/tests');
AUTOLOAD
-: Skip flakey test
-sed 's/function testAddsCookiesWithEmptyPathFromResponse/function SKIP_testAddsCookiesWithEmptyPathFromResponse/' \
- -i tests/Cookie/CookieJarTest.php
-
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit7)
-for PHP_EXEC in "" php71 php72 php73 php74; do
+for PHP_EXEC in php php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+
+ FILTER="testDescribesType|testInvokesOnStatsOnError|testAddsCookiesWithEmptyPathFromResponse|testCreatesExceptionWithoutPrintableBody"
+ VER=$($PHP_EXEC -r 'echo PHP_VERSION_ID;')
+ if [ $VER -ge 80000 ]; then
+ FILTER="$FILTER|testEmitsProgressToFunction|testCreatesCurlHandle"
+ fi
+
$PHP_EXEC $PHPUNIT \
- --filter '^((?!(testDescribesType|testInvokesOnStatsOnError)).)*$' \
+ --filter "^((?!($FILTER)).)*$" \
--verbose || RETURN_CODE=1
fi
done
@@ -220,6 +224,9 @@ exit $RETURN_CODE
%changelog
+* Thu Apr 1 2021 Remi Collet <remi@remirepo.net> - 6.5.5-1
+- update to 6.5.5
+
* Thu Dec 26 2019 Shawn Iwinski <shawn@iwin.ski> - 6.5.2-1
- Update to 6.5.2 (RHBZ #1764727)
- Remove version check and only do autoloader check b/c