summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-30 14:28:27 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-30 14:28:27 +0200
commit80d4906aeb1fa6af9201e63b068762d5588189ec (patch)
treeebdde8f3983d12d4aeae4919be9f07c55d06e058
parent37c78b92233857e75292a64e357bca875262fe93 (diff)
php-guzzlehttp-guzzle: fix for EL-5
-rw-r--r--php-guzzlehttp-guzzle.spec13
1 files changed, 13 insertions, 0 deletions
diff --git a/php-guzzlehttp-guzzle.spec b/php-guzzlehttp-guzzle.spec
index 56eb425..3ff9104 100644
--- a/php-guzzlehttp-guzzle.spec
+++ b/php-guzzlehttp-guzzle.spec
@@ -10,6 +10,12 @@
# Please preserve changelog entries
#
+%if 0%{?rhel} == 5
+%global with_cacert 0
+%else
+%global with_cacert 1
+%endif
+
%global github_owner guzzle
%global github_name guzzle
%global github_version 5.3.0
@@ -28,8 +34,13 @@
%global psr_log_min_ver 1.0
%global psr_log_max_ver 2.0
+%if 0%{?rhel} == 5
+# no nodejs available in RHEL-5
+%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%else
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
+%endif
%{!?phpdir: %global phpdir %{_datadir}/php}
%{!?testsdir: %global testsdir %{_datadir}/tests}
@@ -69,7 +80,9 @@ BuildRequires: php-spl
BuildRequires: php-composer(symfony/class-loader)
%endif
+%if %{with_cacert}
Requires: ca-certificates
+%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
#Requires: php-composer(guzzlehttp/ringphp) >= %%{ring_min_ver}