summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-14 08:35:14 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-14 08:35:14 +0200
commitaa961fd5b237755ce824dcef6d5137ad0fa33bda (patch)
tree46085507f94969d0b34c2a3adb59244b183d1fee
parent923c19c2fb9b7aa7a55c07ae10807165202c1472 (diff)
php-guzzle-Guzzle: sync with fedora
-rw-r--r--php-guzzle-Guzzle-doctrine-cache-gte-1-6-0.patch32
-rw-r--r--php-guzzle-Guzzle.spec29
2 files changed, 45 insertions, 16 deletions
diff --git a/php-guzzle-Guzzle-doctrine-cache-gte-1-6-0.patch b/php-guzzle-Guzzle-doctrine-cache-gte-1-6-0.patch
index 2adbfcb..b1c81c6 100644
--- a/php-guzzle-Guzzle-doctrine-cache-gte-1-6-0.patch
+++ b/php-guzzle-Guzzle-doctrine-cache-gte-1-6-0.patch
@@ -1,7 +1,7 @@
From b19a1edb61244df53e532cade85bd3e16fef338d Mon Sep 17 00:00:00 2001
From: Shawn Iwinski <siwinski@redhat.com>
Date: Mon, 21 Mar 2016 11:53:07 -0400
-Subject: [PATCH 1/4] Update tests to allow for Doctrine Cache >= 1.6.0
+Subject: [PATCH 1/5] Update tests to allow for Doctrine Cache >= 1.6.0
internal changes
---
@@ -87,7 +87,7 @@ index 701a015..987c4a3 100644
From 9312343b4cd020a57f73ca985828ecb4e360b410 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?David=20Pr=C3=A9vot?= <david@tilapin.org>
Date: Thu, 26 Nov 2015 14:07:41 -0400
-Subject: [PATCH 2/4] Match latest (>= 1.4.3) Doctrine Cache behaviour
+Subject: [PATCH 2/5] Match latest (>= 1.4.3) Doctrine Cache behaviour
Bug: https://github.com/guzzle/guzzle3/issues/67
Bug-Debian: https://bugs.debian.org/804583
@@ -112,7 +112,7 @@ index 987c4a3..dbfd810 100644
From f3041fb232862b4c449a23497cc70225574bfcc0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?David=20Pr=C3=A9vot?= <david@tilapin.org>
Date: Thu, 26 Nov 2015 14:17:15 -0400
-Subject: [PATCH 3/4] Bump doctrine/cache version
+Subject: [PATCH 3/5] Bump doctrine/cache version
---
composer.json | 2 +-
@@ -135,7 +135,7 @@ index 59424b3..f2040cf 100644
From ad90c2d4471aaf9a591df207c3cdbe5c531371e2 Mon Sep 17 00:00:00 2001
From: Shawn Iwinski <siwinski@redhat.com>
Date: Thu, 24 Mar 2016 08:19:05 -0400
-Subject: [PATCH 4/4] Modify doctrine/cache dependency from ~1.4.3 to ~1.4 per
+Subject: [PATCH 4/5] Modify doctrine/cache dependency from ~1.4.3 to ~1.4 per
#69
---
@@ -155,3 +155,27 @@ index f2040cf..f0bfdb6 100644
"symfony/class-loader": "~2.1",
"monolog/monolog": "~1.0",
"psr/log": "~1.0",
+
+From 2ddcdd7646fc7756468fd63b71d7d0d9545dc76e Mon Sep 17 00:00:00 2001
+From: Shawn Iwinski <siwinski@redhat.com>
+Date: Thu, 24 Mar 2016 14:17:56 -0400
+Subject: [PATCH 5/5] Modify doctrine/cache dependency from ~1.4 to
+ ~1.4,>=1.4.3
+
+---
+ composer.json | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/composer.json b/composer.json
+index f0bfdb6..ebf5dde 100644
+--- a/composer.json
++++ b/composer.json
+@@ -65,7 +65,7 @@
+ },
+
+ "require-dev": {
+- "doctrine/cache": "~1.4",
++ "doctrine/cache": "~1.4,>=1.4.3",
+ "symfony/class-loader": "~2.1",
+ "monolog/monolog": "~1.0",
+ "psr/log": "~1.0",
diff --git a/php-guzzle-Guzzle.spec b/php-guzzle-Guzzle.spec
index 1468a50..cb375c7 100644
--- a/php-guzzle-Guzzle.spec
+++ b/php-guzzle-Guzzle.spec
@@ -29,10 +29,7 @@
# "php": ">=5.3.3"
%global php_min_ver 5.3.3
-# "doctrine/cache": "~1.4"
-# NOTE: Min version not 1.4 because:
-# 1) autoloader required
-# 2) original patch required >= 1.4.3 (see patch below for details)
+# "doctrine/cache": "~1.4,>=1.4.3"
%global doctrine_cache_min_ver 1.4.3
%global doctrine_cache_max_ver 2.0
# "monolog/monolog": "~1.0"
@@ -66,7 +63,7 @@
Name: php-guzzle-%{pear_name}
Version: %{github_version}
-Release: 8%{?dist}
+Release: 9%{?dist}
Summary: PHP HTTP client library and framework for building RESTful web service clients
Group: Development/Libraries
@@ -257,13 +254,17 @@ if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Compo
$fedoraClassLoader->addPrefix('Guzzle\\', dirname(__DIR__));
-// Required dependencies
-require_once '%{phpdir}/Symfony/Component/EventDispatcher/autoload.php';
-
-// Optional dependencies
-@include_once '%{phpdir}/Doctrine/Common/Cache/autoload.php';
-@include_once '%{phpdir}/Monolog/autoload.php';
-@include_once '%{phpdir}/Zend/autoload.php';
+// Dependencies (autoloader => required)
+foreach(array(
+ '%{phpdir}/Doctrine/Common/Cache/autoload.php' => false,
+ '%{phpdir}/Monolog/autoload.php' => false,
+ '%{phpdir}/Symfony/Component/EventDispatcher/autoload.php' => true,
+ '%{phpdir}/Zend/autoload.php' => false,
+) as $dependencyAutoloader => $required) {
+ if ($required || file_exists($dependencyAutoloader)) {
+ require_once $dependencyAutoloader;
+ }
+}
return $fedoraClassLoader;
AUTOLOAD
@@ -364,6 +365,10 @@ fi
%exclude %{phpdir}/Guzzle/*/*/composer.json
%changelog
+* Wed Apr 13 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.9.3-9
+- Re-rolled patch
+- Updated autoloader dependency loading
+
* Thu Mar 24 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.9.3-8
- Add patches for tests
- Use actual dependency autoloaders instead of failover include path