summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-02-07 17:36:11 +0100
committerRemi Collet <fedora@famillecollet.com>2013-02-07 17:36:11 +0100
commit545698e27b74cd38731387459ba2b5afa06cb68c (patch)
tree1d95473091da24ecf050f3146e5c5694cb983912
parent9d37e40116d853718f3d843ec31471503f5f780d (diff)
php-guzzle-Guzzle: backport
-rw-r--r--Makefile10
-rw-r--r--php-guzzle-Guzzle.spec9
2 files changed, 17 insertions, 2 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-guzzle-Guzzle.spec b/php-guzzle-Guzzle.spec
index adcea10..3ab257f 100644
--- a/php-guzzle-Guzzle.spec
+++ b/php-guzzle-Guzzle.spec
@@ -14,11 +14,12 @@ License: MIT
URL: http://guzzlephp.org
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-Requires: php-common >= 5.3.2
+Requires: php(language) >= 5.3.2
Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires: php-pear(pear.symfony.com/EventDispatcher) >= 2.1.0
@@ -36,7 +37,7 @@ Requires: php-pcre
Requires: php-reflection
Requires: php-simplexml
Requires: php-spl
-%{?fedora:Requires: php-filter}
+Requires: php-filter
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -115,12 +116,16 @@ fi
%files
+%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/%{pear_name}
%changelog
+* Thu Feb 7 2013 Remi Collet <remi@fedoraproject.org> - 3.1.2-1
+- backport 3.1.2 for remi repo.
+
* Mon Feb 04 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 3.1.2-1
- Updated to upstream version 3.1.2
- Removed bundled cert