summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-09 12:31:27 +0100
committerRemi Collet <remi@remirepo.net>2017-11-09 12:31:27 +0100
commit02010b606126eb2bfa6d0f99b73e5a5e9b8bd2ca (patch)
treec6f3b256a685958c80c34b4846d2d51b37d1745a
parentd9d5196acfc2195913d8c68edca0d13967d39ae3 (diff)
fix FTBFS from Koschei, add patch for PHP 7.2
-rw-r--r--php-guzzle-Guzzle.spec12
1 files changed, 9 insertions, 3 deletions
diff --git a/php-guzzle-Guzzle.spec b/php-guzzle-Guzzle.spec
index f3cf3a0..7f3e766 100644
--- a/php-guzzle-Guzzle.spec
+++ b/php-guzzle-Guzzle.spec
@@ -53,7 +53,7 @@
Name: php-guzzle-%{pear_name}
Version: %{github_version}
-Release: 13%{?dist}
+Release: 14%{?dist}
Summary: PHP HTTP client library and framework for building RESTful web service clients
Group: Development/Libraries
@@ -64,6 +64,8 @@ Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{githu
# Update tests to allow for Doctrine Cache >= 1.6.0 internal changes
# https://github.com/guzzle/guzzle3/pull/77
Patch0: %{name}-doctrine-cache-gte-1-6-0.patch
+# For PHP 7.2, not upstreamable as this version is too old
+Patch1: %{name}-php72.patch
BuildArch: noarch
# Tests
@@ -104,7 +106,6 @@ BuildRequires: php-zlib
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
-# Need investigation
# composer.json
Requires: php(language) >= %{php_min_ver}
@@ -212,6 +213,8 @@ some point in late 2015.
: Update tests to allow for Doctrine Cache >= 1.6.0 internal changes
%patch0 -p1
+: For PHP 7.2
+%patch1 -p1
: Unbundle CA certificate
sed -e "s#__DIR__\s*.\s*'/Resources/cacert.pem'#'%{_sysconfdir}/pki/tls/cert.pem'#" \
@@ -314,7 +317,7 @@ sed 's/function testMustReturnRequest/function SKIP_testMustReturnRequest/' \
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71; do
+for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
fi
@@ -348,6 +351,9 @@ fi
%changelog
+* Thu Nov 9 2017 Remi Collet <remi@remirepo.net> - 3.9.3-14
+- fix FTBFS from Koschei, add patch for PHP 7.2
+
* Thu Sep 21 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.9.3-13
- Add max versions to BuildRequires
- Modify tests