summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json33
-rw-r--r--php-grasmash-yaml-expander.spec1
4 files changed, 46 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..cbd8ede
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,33 @@
+{
+ "name": "grasmash/yaml-expander",
+ "description": "Expands internal property references in a yaml file.",
+ "type": "library",
+ "require": {
+ "php": ">=5.4",
+ "symfony/yaml": "^2.8.11|^3",
+ "dflydev/dot-access-data": "^1.1.0"
+ },
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Matthew Grasmick"
+ }
+ ],
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "autoload": {
+ "psr-4": {
+ "Grasmash\\YamlExpander\\": "src/"
+ }
+ },
+ "require-dev": {
+ "squizlabs/php_codesniffer": "^2.7",
+ "phpunit/phpunit": "^4.8|^5.5.4",
+ "satooshi/php-coveralls": "^1.0"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.x-dev"
+ }
+ }
+}
diff --git a/php-grasmash-yaml-expander.spec b/php-grasmash-yaml-expander.spec
index 2e0fb7d..b56a447 100644
--- a/php-grasmash-yaml-expander.spec
+++ b/php-grasmash-yaml-expander.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-grasmash-yaml-expander
#
# Fedora spec file for php-grasmash-yaml-expander
#