summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-19 13:49:58 +0200
committerRemi Collet <remi@remirepo.net>2019-06-19 13:49:58 +0200
commitfe4bb4f9f385b464d81e23609db78cf8dfd0ed07 (patch)
treec13bde5cd35b72232e6b67069cbaf63f847f567d
parenta58f176566ee036fb409ee5f69fbc3817c1bf405 (diff)
v1.2.2
-rw-r--r--Makefile2
-rw-r--r--composer.json4
-rw-r--r--php-google-recaptcha.spec19
3 files changed, 14 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index 91b0fd5..13af741 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-include ../../common/Makefile
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
index d4695b7..ab6b4f1 100644
--- a/composer.json
+++ b/composer.json
@@ -13,8 +13,8 @@
"php": ">=5.5"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.36|^5.7.27|^6.59|^7",
- "friendsofphp/php-cs-fixer": "^2.2.20|^2.12",
+ "phpunit/phpunit": "^4.8.36|^5.7.27|^6.59|^7.5.11",
+ "friendsofphp/php-cs-fixer": "^2.2.20|^2.15",
"php-coveralls/php-coveralls": "^2.1"
},
"autoload": {
diff --git a/php-google-recaptcha.spec b/php-google-recaptcha.spec
index 61bb4b1..d84c514 100644
--- a/php-google-recaptcha.spec
+++ b/php-google-recaptcha.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-google-recaptcha
#
-# Copyright (c) 2017 Remi Collet
+# Copyright (c) 2017-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit e7add3be59211482ecdb942288f52da64a35f61a
+%global gh_commit c4a17d6af648d4f3814430cd103cba50b75b571c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner google
%global gh_project recaptcha
@@ -14,11 +14,10 @@
%global psr0 ReCaptcha
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.2.1
+Version: 1.2.2
Release: 1%{?dist}
Summary: reCAPTCHA PHP client library
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{url}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
@@ -32,14 +31,15 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": "^4.8.36|^5.7.27|^6.59|^7"
+# "phpunit/phpunit": "^4.8.36|^5.7.27|^6.59|^7.5.11",
+# "friendsofphp/php-cs-fixer": "^2.2.20|^2.15",
# remirepo:1
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-BuildRequires: phpunit7
+BuildRequires: phpunit7 >= 7.5.11
%global phpunit %{_bindir}/phpunit7
# remirepo:4
%else
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8.36
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.27
%global phpunit %{_bindir}/phpunit
%endif
%endif
@@ -101,7 +101,7 @@ cp -pr src/%{psr0} %{buildroot}%{_datadir}/php/%{psr0}
BOOTSTRAP=%{buildroot}%{_datadir}/php/%{psr0}/autoload.php
ret=0
-for cmdarg in "php %phpunit" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
+for cmdarg in "php %phpunit" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --bootstrap=$BOOTSTRAP --verbose || ret=0
@@ -122,6 +122,9 @@ exit $ret
%changelog
+* Wed Jun 19 2019 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+
* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1
- use phpunit7