summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json25
-rw-r--r--php-google-apiclient1.spec5
4 files changed, 40 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..224d0b6
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,25 @@
+{
+ "name": "google/apiclient",
+ "type": "library",
+ "description": "Client library for Google APIs",
+ "keywords": ["google"],
+ "homepage": "http://developers.google.com/api-client-library/php",
+ "license": "Apache-2.0",
+ "require": {
+ "php": ">=5.2.1"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "3.7.*",
+ "squizlabs/php_codesniffer": "~2.3"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1.x-dev"
+ }
+ }
+}
diff --git a/php-google-apiclient1.spec b/php-google-apiclient1.spec
index 9cdfadf..7c4ddd7 100644
--- a/php-google-apiclient1.spec
+++ b/php-google-apiclient1.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-google-apiclient1, from:
#
# Fedora spec file for php-google-apiclient1
#
@@ -65,7 +66,7 @@ Requires: php-reflection
Requires: php-spl
# Weak dependencies
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-pecl(apcu)
Suggests: php-pecl(memcache)
Suggests: php-pecl(memcached)
@@ -136,7 +137,7 @@ rm -f tests/general/ApiBatchRequestTest.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in %{_bindir}/php %{?rhel:php54 php55} php56 php70 php71; do
+for PHP_EXEC in %{_bindir}/php %{?rhel:php54 php55 php56 php70} php71 php72 php73 php74; do
if [ "%{_bindir}/php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit || RETURN_CODE=1
fi