summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-17 14:45:06 +0200
committerRemi Collet <remi@remirepo.net>2020-08-17 14:45:06 +0200
commitc7c5a04e2dd7312bd0ac9259327be0ad8cd9b475 (patch)
tree7aa27db4722b7582f398d4a3b281ab5834744aea
parent33345bf6be9897af457da77dfe52dcebe5d22d5a (diff)
v2.6.0 from Fedora
-rw-r--r--composer.json96
-rw-r--r--php-gettext-languages.spec16
2 files changed, 63 insertions, 49 deletions
diff --git a/composer.json b/composer.json
index 3d5911d..ae56958 100644
--- a/composer.json
+++ b/composer.json
@@ -1,46 +1,54 @@
{
- "name" : "gettext/languages",
- "description" : "gettext languages with plural rules",
- "keywords" : [
- "localization",
- "l10n",
- "internationalization",
- "i18n",
- "translations",
- "translate",
- "php",
- "unicode",
- "cldr",
- "language",
- "languages",
- "plural",
- "plurals",
- "plural rules"
- ],
- "homepage" : "https://github.com/mlocati/cldr-to-gettext-plural-rules",
- "license" : "MIT",
- "authors" : [{
- "name" : "Michele Locati",
- "email" : "mlocati@gmail.com",
- "role" : "Developer"
- }
- ],
- "autoload" : {
- "psr-4" : {
- "Gettext\\Languages\\" : "src/"
- }
- },
- "require" : {
- "php" : ">=5.3"
- },
- "require-dev": {
- "phpunit/phpunit": "^4"
- },
- "scripts": {
- "test": "phpunit"
- },
- "bin" : [
- "bin/export-plural-rules",
- "bin/export-plural-rules.php"
- ]
+ "name": "gettext/languages",
+ "description": "gettext languages with plural rules",
+ "keywords": [
+ "localization",
+ "l10n",
+ "internationalization",
+ "i18n",
+ "translations",
+ "translate",
+ "php",
+ "unicode",
+ "cldr",
+ "language",
+ "languages",
+ "plural",
+ "plurals",
+ "plural rules"
+ ],
+ "homepage": "https://github.com/php-gettext/Languages",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Michele Locati",
+ "email": "mlocati@gmail.com",
+ "role": "Developer"
+ }
+ ],
+ "autoload": {
+ "psr-4": {
+ "Gettext\\Languages\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Gettext\\Languages\\Test\\": "tests/test/"
+ }
+ },
+ "require": {
+ "php": ">=5.3"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.8 || ^5.7 || ^6.5 || ^7.5 || ^8.4",
+ "friendsofphp/php-cs-fixer": "^2.16.0"
+ },
+ "scripts": {
+ "test": "phpunit",
+ "cs-test": "php-cs-fixer fix --config=.php_cs.dist --path-mode=intersection --verbose --dry-run --diff",
+ "cs-fix": "php-cs-fixer fix --config=.php_cs.dist --path-mode=intersection"
+ },
+ "bin": [
+ "bin/export-plural-rules"
+ ]
} \ No newline at end of file
diff --git a/php-gettext-languages.spec b/php-gettext-languages.spec
index 6853009..db2a87a 100644
--- a/php-gettext-languages.spec
+++ b/php-gettext-languages.spec
@@ -9,7 +9,7 @@
#
Name: php-gettext-languages
-Version: 2.4.0
+Version: 2.6.0
Release: 1%{?dist}
BuildArch: noarch
@@ -50,9 +50,11 @@ generated from CLDR data.
%prep
%autosetup -p1 -n cldr-to-gettext-plural-rules-%{version}
-sed -i "s:require_once.*:require_once '%{_datadir}/php/Gettext/Languages/autoloader.php';:" bin/export-plural-rules.php
-echo "#!/usr/bin/env php" > bin/export-plural-rules.sh
-cat bin/export-plural-rules.sh bin/export-plural-rules.php > bin/export-plural-rules
+sed -i "s:require_once.*:require_once '%{_datadir}/php/Gettext/Languages/autoloader.php';:" bin/export-plural-rules
+#echo "#!/usr/bin/env php" > bin/export-plural-rules.sh
+#cat bin/export-plural-rules.sh bin/export-plural-rules.php > bin/export-plural-rules
+
+sed -i '1s;^;#!/usr/bin/php\n;' bin/export-plural-rules
%install
@@ -65,12 +67,13 @@ cp -a bin/export-plural-rules %{buildroot}/%{_bindir}/%{name}-export-plural-rule
chmod 755 %{buildroot}/%{_bindir}/%{name}-export-plural-rules
cp -ar src/* %{buildroot}/%{_datadir}/php/Gettext/Languages/
+cp -ar tests/test %{buildroot}/%{_datadir}/php/Gettext/Languages/Test
%check
sed -i "s:require_once.*:require_once '%{buildroot}/%{_datadir}/php/Gettext/Languages/autoloader.php';:" tests/bootstrap.php
-sed -i "s:require_once.*:require_once '%{buildroot}/%{_datadir}/php/Gettext/Languages/autoloader.php';:" bin/export-plural-rules.php
+sed -i "s:require_once.*:require_once '%{buildroot}/%{_datadir}/php/Gettext/Languages/autoloader.php';:" bin/export-plural-rules
phpunit --bootstrap tests/bootstrap.php
@@ -85,6 +88,9 @@ phpunit --bootstrap tests/bootstrap.php
%changelog
+* Fri Jul 24 2020 Sundeep Anand <suanand@fedoraproject.org> - 2.6.0-1
+- Update to 2.6.0 (#1772151).
+
* Sun Jul 29 2018 Randy Barlow <bowlofeggs@fedoraproject.org> - 2.4.0-1
- Update to 2.4.0 (#1594776).
- https://github.com/mlocati/cldr-to-gettext-plural-rules/releases/tag/2.4.0