summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-16 14:40:16 +0100
committerRemi Collet <remi@remirepo.net>2018-01-16 14:40:16 +0100
commit45b1172ac143d5d20002de8bad329a152f42b37f (patch)
tree8ed00e46ca8a0a7332f300b192e0edcf6b135145
parent25de79841f21238e7ea71f3b7ef328600e37acb8 (diff)
ass backport stuff
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json46
-rw-r--r--php-gettext-languages.spec11
4 files changed, 69 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..3d5911d
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,46 @@
+{
+ "name" : "gettext/languages",
+ "description" : "gettext languages with plural rules",
+ "keywords" : [
+ "localization",
+ "l10n",
+ "internationalization",
+ "i18n",
+ "translations",
+ "translate",
+ "php",
+ "unicode",
+ "cldr",
+ "language",
+ "languages",
+ "plural",
+ "plurals",
+ "plural rules"
+ ],
+ "homepage" : "https://github.com/mlocati/cldr-to-gettext-plural-rules",
+ "license" : "MIT",
+ "authors" : [{
+ "name" : "Michele Locati",
+ "email" : "mlocati@gmail.com",
+ "role" : "Developer"
+ }
+ ],
+ "autoload" : {
+ "psr-4" : {
+ "Gettext\\Languages\\" : "src/"
+ }
+ },
+ "require" : {
+ "php" : ">=5.3"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4"
+ },
+ "scripts": {
+ "test": "phpunit"
+ },
+ "bin" : [
+ "bin/export-plural-rules",
+ "bin/export-plural-rules.php"
+ ]
+} \ No newline at end of file
diff --git a/php-gettext-languages.spec b/php-gettext-languages.spec
index ce6be40..feec9be 100644
--- a/php-gettext-languages.spec
+++ b/php-gettext-languages.spec
@@ -1,3 +1,13 @@
+# remirepo spec file for php-gettext-languages, from
+#
+# Fedora spec file for php-gettext-languages
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
%global gh_commit 49c39e51569963cc917a924b489e7025bfb9d8c7
%global gh_short %(c=%{gh_commit}; echo ${c:0:8})
%global gh_owner mlocati
@@ -62,6 +72,7 @@ phpunit --bootstrap tests/bootstrap.php
%files
+%{!?_licensedir:%global license %%doc}
%license LICENSE
%license UNICODE-LICENSE.txt
%doc composer.json