summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--0000-don-t-check-Po-file-content-on-bigendian.patch4
-rwxr-xr-xdltests.sh25
-rw-r--r--php-gettext-gettext.spec20
4 files changed, 40 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
index fc9aa8c..6f69818 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@ clog
package-*.xml
*.tgz
*.tar.gz
+*.tar.bz2
*.tar.xz
*.tar.xz.asc
*.src.rpm
diff --git a/0000-don-t-check-Po-file-content-on-bigendian.patch b/0000-don-t-check-Po-file-content-on-bigendian.patch
index cae787f..dc09460 100644
--- a/0000-don-t-check-Po-file-content-on-bigendian.patch
+++ b/0000-don-t-check-Po-file-content-on-bigendian.patch
@@ -1,4 +1,4 @@
-From 73c0f65dad03f1beff820b415af12eba3f1f6601 Mon Sep 17 00:00:00 2001
+From aadd696ee850da3e3e387dd32b9406905cd14e2b Mon Sep 17 00:00:00 2001
From: Randy Barlow <randy@electronsweatshop.com>
Date: Mon, 15 Jan 2018 15:59:10 -0500
Subject: [PATCH] don't check Po file content on bigendian
@@ -38,5 +38,5 @@ index 42f54b6..42f419f 100644
+ }
}
--
-2.15.1
+2.16.1
diff --git a/dltests.sh b/dltests.sh
new file mode 100755
index 0000000..f27ee02
--- /dev/null
+++ b/dltests.sh
@@ -0,0 +1,25 @@
+#!/bin/bash
+# This was borrowed from nodejs-grunt-contrib-concat
+
+tag=v4.4.4
+
+set -e
+
+tmp=$(mktemp -d)
+
+trap cleanup EXIT
+cleanup() {
+ set +e
+ [ -z "$tmp" -o ! -d "$tmp" ] || rm -rf "$tmp"
+}
+
+unset CDPATH
+pwd=$(pwd)
+
+pushd "$tmp"
+git clone https://github.com/oscarotero/Gettext.git
+ls
+cd Gettext
+git archive --prefix="tests/" --format=tar ${tag}:tests/ \
+ | bzip2 > "$pwd"/tests-${tag}.tar.bz2
+popd
diff --git a/php-gettext-gettext.spec b/php-gettext-gettext.spec
index 284a2b5..d030284 100644
--- a/php-gettext-gettext.spec
+++ b/php-gettext-gettext.spec
@@ -8,22 +8,22 @@
# Please preserve changelog entries
#
-%global gh_commit 4f57f004635cc6311a20815ebfdc0757cb337113
-%global gh_short %(c=%{gh_commit}; echo ${c:0:8})
%global gh_owner oscarotero
%global gh_project Gettext
Name: php-gettext-gettext
-Version: 4.4.3
+Version: 4.4.4
Release: 1%{?dist}
BuildArch: noarch
License: MIT
Summary: PHP gettext manager
URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{url}/archive/v%{version}/%{gh_project}-%{version}.tar.gz
# Upstream strips the tests from the tarball, so we have to generate it manually.
-Source0: %{gh_project}-%{version}.tar.gz
+# dltests.sh is used to do this, and is included in this repository.
+Source1: tests-v%{version}.tar.bz2
# Skip some tests on bigendian as reference file are littleendian
# https://github.com/oscarotero/Gettext/pull/159
@@ -58,13 +58,11 @@ Autoloader: %{_datadir}/php/Gettext/autoload.php
%prep
-%autosetup -p1 -n Gettext-%{version}
+%autosetup -p1 -a1 -n Gettext-%{version}
# The documentation has the wrong newline codes
dos2unix *.md
-sed -i "s:include_once.*:\ninclude_once '%{buildroot}/%{_datadir}/php/Gettext/autoload.php';:" tests/bootstrap.php
-
%build
: Create autoloader
@@ -93,11 +91,13 @@ cp -ar src/* %{buildroot}/%{_datadir}/php/Gettext/
%check
+sed -i "s:include_once.*:\ninclude_once '%{buildroot}/%{_datadir}/php/Gettext/autoload.php';:" tests/bootstrap.php
+
# gettext has some optional dependencies that we are not integrating with at this time (we can later
# if desired). Thus, we need to skip the tests on these integration points since they will fail
# without the dependencies. There is an upstream issue about compatibility issues with Twig:
# https://github.com/oscarotero/Gettext/issues/137
-phpunit --bootstrap tests/bootstrap.php --filter ^\(\(?!\(testBlade\|testTwig\)\).\)*$
+phpunit --bootstrap tests/bootstrap.php --filter ^\(\(?!\(testBlade\|testTwig\)\).\)*$ tests
%files
@@ -111,6 +111,10 @@ phpunit --bootstrap tests/bootstrap.php --filter ^\(\(?!\(testBlade\|testTwig\)\
%changelog
+* Sun Feb 25 2018 Randy Barlow <bowlofeggs@fedoraproject.org> - 4.4.4-1
+- Update to 4.4.4 (#1548216).
+- https://github.com/oscarotero/Gettext/blob/v4.4.4/CHANGELOG.md
+
* Sun Dec 17 2017 Randy Barlow <bowlofeggs@fedoraproject.org> - 4.4.3-1
- Update to 4.4.3 (#1450031).
- https://github.com/oscarotero/Gettext/blob/v4.4.3/CHANGELOG.md