summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-16 14:43:46 +0100
committerRemi Collet <remi@remirepo.net>2018-01-16 14:43:46 +0100
commitc29ede419f705b7402c9193f7b0c786e79a1dab2 (patch)
treee2f9563e6b99de2b42861fc5ca1f0e5c933beb37
parent482ec23c2f5af6590ada07501258e02bd488bca0 (diff)
add backport stuff
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json54
-rw-r--r--php-gettext-gettext.spec11
4 files changed, 77 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..9f83874
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,54 @@
+{
+ "name": "gettext/gettext",
+ "type": "library",
+ "description": "PHP gettext manager",
+ "keywords": ["js", "gettext", "i18n", "translation", "po", "mo"],
+ "homepage": "https://github.com/oscarotero/Gettext",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Oscar Otero",
+ "email": "oom@oscarotero.com",
+ "homepage": "http://oscarotero.com",
+ "role": "Developer"
+ }
+ ],
+ "support": {
+ "email": "oom@oscarotero.com",
+ "issues": "https://github.com/oscarotero/Gettext/issues"
+ },
+ "require": {
+ "php": ">=5.4.0",
+ "gettext/languages": "^2.3"
+ },
+ "require-dev": {
+ "illuminate/view": "*",
+ "twig/twig": "^1.31|^2.0",
+ "twig/extensions": "*",
+ "symfony/yaml": "~2",
+ "phpunit/phpunit": "^4.8|^5.7",
+ "squizlabs/php_codesniffer": "^3.0"
+ },
+ "suggest": {
+ "illuminate/view": "Is necessary if you want to use the Blade extractor",
+ "twig/twig": "Is necessary if you want to use the Twig extractor",
+ "twig/extensions": "Is necessary if you want to use the Twig extractor",
+ "symfony/yaml": "Is necessary if you want to use the Yaml extractor/generator"
+ },
+ "autoload": {
+ "psr-4": {
+ "Gettext\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Gettext\\Tests\\": "tests"
+ }
+ },
+ "scripts": {
+ "test": [
+ "phpunit",
+ "phpcs"
+ ]
+ }
+}
diff --git a/php-gettext-gettext.spec b/php-gettext-gettext.spec
index be193a5..284a2b5 100644
--- a/php-gettext-gettext.spec
+++ b/php-gettext-gettext.spec
@@ -1,3 +1,13 @@
+# remirepo spec file for php-gettext-gettext, from
+#
+# Fedora spec file for php-gettext-gettext
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
%global gh_commit 4f57f004635cc6311a20815ebfdc0757cb337113
%global gh_short %(c=%{gh_commit}; echo ${c:0:8})
%global gh_owner oscarotero
@@ -91,6 +101,7 @@ phpunit --bootstrap tests/bootstrap.php --filter ^\(\(?!\(testBlade\|testTwig\)\
%files
+%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc CHANGELOG.md
%doc composer.json