summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-25 10:03:08 +0100
committerRemi Collet <remi@remirepo.net>2018-01-25 10:03:08 +0100
commitb63822ba7954d729ace9416173f620b02fa9779b (patch)
tree8ab1010260e86c244c49ac23a5639348718c4922
parent034ea5a81212045b1ab1b5ae224047e3fc95d467 (diff)
v3.1
-rw-r--r--composer.json5
-rw-r--r--php-gecko-packages-gecko-php-unit3.spec9
2 files changed, 10 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index a00c3e1..759af0c 100644
--- a/composer.json
+++ b/composer.json
@@ -8,6 +8,9 @@
"require": {
"php": "^7.0"
},
+ "conflict": {
+ "phpunit/phpunit": "<6.0"
+ },
"require-dev": {
"phpunit/phpunit": "^6.0"
},
@@ -28,6 +31,6 @@
"suggest": {
"ext-dom": "When testing with xml.",
"ext-libxml": "When testing with xml.",
- "phpunit/phpunit" : "This is an extension for it so make sure you have it some way."
+ "phpunit/phpunit" : "This is an extension for PHPUnit so make sure you have that in some way."
}
}
diff --git a/php-gecko-packages-gecko-php-unit3.spec b/php-gecko-packages-gecko-php-unit3.spec
index 1a8c0ef..e2f2677 100644
--- a/php-gecko-packages-gecko-php-unit3.spec
+++ b/php-gecko-packages-gecko-php-unit3.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-gecko-packages-gecko-php-unit3
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 6a866551dffc2154c1b091bae3a7877d39c25ca3
+%global gh_commit dbb18b292cfa14444d2e6d15202b9dcf5ab8365e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner GeckoPackages
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_owner}-%{pk_project}%{major}
-Version: 3.0
+Version: 3.1
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Additional PHPUnit asserts and constraints
@@ -121,6 +121,9 @@ exit $ret
%changelog
+* Thu Jan 25 2018 Remi Collet <remi@remirepo.net> - 3.1-1
+- Update to 3.1
+
* Fri Nov 3 2017 Remi Collet <remi@remirepo.net> - 3.0-1
- Update to 3.0
- rename to php-gecko-packages-gecko-php-unit3