summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-03 06:28:59 +0100
committerRemi Collet <remi@remirepo.net>2017-11-03 06:28:59 +0100
commit3c849e1e011401a5674b8331e06f3577d207e468 (patch)
tree0a9cac1d95ea22162a2b111b69c47992cfc49def
import v2
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json28
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-gecko-packages-gecko-php-unit3.spec131
5 files changed, 198 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..febdd23
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,28 @@
+{
+ "name": "gecko-packages/gecko-php-unit",
+ "type": "library",
+ "homepage": "https://github.com/GeckoPackages",
+ "description": "Additional PHPUnit asserts and constraints.",
+ "license": "MIT",
+ "keywords": ["PHPUnit", "Extension", "FileSystem"],
+ "require": {
+ "php": "^5.3.6 || ^7.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.8.35 || ^5.4.3"
+ },
+ "autoload": {
+ "psr-4": {
+ "GeckoPackages\\PHPUnit\\": "src/PHPUnit"
+ }
+ },
+ "config": {
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "suggest": {
+ "ext-dom": "When testing with xml.",
+ "ext-libxml": "When testing with xml.",
+ "phpunit/phpunit" : "This is an extension for it so make sure you have it some way."
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..7c824f0
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=php-gecko-packages-gecko-php-unit
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-gecko-packages-gecko-php-unit3.spec b/php-gecko-packages-gecko-php-unit3.spec
new file mode 100644
index 0000000..226f949
--- /dev/null
+++ b/php-gecko-packages-gecko-php-unit3.spec
@@ -0,0 +1,131 @@
+# remirepo/fedora spec file for php-gecko-packages-gecko-php-unit
+#
+# Copyright (c) 2016-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit ab525fac9a9ffea219687f261b02008b18ebf2d1
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+#global gh_date 20150717
+%global gh_owner GeckoPackages
+%global gh_project GeckoPHPUnit
+%global pk_owner gecko-packages
+%global pk_project gecko-php-unit
+%global php_home %{_datadir}/php
+%global with_tests 0%{!?_without_tests:1}
+
+Name: php-%{pk_owner}-%{pk_project}
+Version: 2.2
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Summary: Additional PHPUnit asserts and constraints
+
+Group: Development/Tools
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snapshot to get upstream test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with_tests}
+# For tests
+BuildRequires: php(language) >= 5.3.6
+BuildRequires: php-dom
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "4.0"
+BuildRequires: php-composer(phpunit/phpunit)
+# Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# From composer.json, "require": {
+# "php": "^5.3.6 || ^7.0"
+Requires: php(language) >= 5.3.6
+# From phpcompatinfo report for version 2.2
+Requires: php-dom
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_owner}/%{pk_project}) = %{version}
+
+
+%description
+Provides additional asserts to be used in PHPUnit tests.
+The asserts are provided using Traits so no changes are needed
+in the hierarchy of test classes.
+
+Autoloader: %{php_home}/GeckoPackages/PHPUnit/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+cat << 'EOF' | tee src/PHPUnit/autoload.php
+<?php
+/* Autoloader for friendsofphp/php-cs-fixer and its dependencies */
+
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('GeckoPackages\\PHPUnit\\', __DIR__);
+
+EOF
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/GeckoPackages
+cp -pr src/PHPUnit %{buildroot}%{php_home}/GeckoPackages/PHPUnit
+
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+ln -s %{buildroot}%{php_home}/GeckoPackages/PHPUnit/autoload.php vendor/autoload.php
+
+: Fix paths in unit tests
+for unit in $(find tests -name \*Test.php -print); do
+ sed -e 's:PHPUnit/tests:tests:' -i $unit
+done
+
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%dir %{php_home}/GeckoPackages
+ %{php_home}/GeckoPackages/PHPUnit
+
+
+%changelog
+* Thu Aug 24 2017 Remi Collet <remi@remirepo.net> - 2.2-1
+- Update to 2.2
+
+* Wed Jun 28 2017 Remi Collet <remi@remirepo.net> - 2.1-1
+- Update to 2.1
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- initial package, version 2.0.0
+