summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json24
-rw-r--r--php-flow-jsonpath.spec1
4 files changed, 36 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..7bf7edc
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,24 @@
+{
+ "name": "flow/jsonpath",
+ "description": "JSONPath implementation for parsing, searching and flattening arrays",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Stephen Frank",
+ "email": "stephen@flowsa.com"
+ }
+ ],
+ "autoload": {
+ "psr-0": {
+ "Flow\\JSONPath": "src/",
+ "Flow\\JSONPath\\Test": "tests/"
+ }
+ },
+ "require": {
+ "php": ">=5.4.0"
+ },
+ "require-dev": {
+ "peekmo/jsonpath": "dev-master",
+ "phpunit/phpunit": "^4.0"
+ }
+}
diff --git a/php-flow-jsonpath.spec b/php-flow-jsonpath.spec
index 44617de..160cee8 100644
--- a/php-flow-jsonpath.spec
+++ b/php-flow-jsonpath.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-flow-jsonpath
#
# Fedora spec file for php-flow-jsonpath
#