summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-13 19:18:06 +0200
committerRemi Collet <remi@remirepo.net>2017-06-13 19:18:06 +0200
commit114360eb5bbc48e7ec6c991decbb8a545ee3ee28 (patch)
treeec99eca8fc00ad5cf39c0c547059ecf4c4c440f0
parent2ce1e7d3ae37afc14b04bebac03cf46fedf5d7dd (diff)
backport
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json35
-rwxr-xr-xphp-fig-link-util-get-source.sh4
-rw-r--r--php-fig-link-util.spec1
5 files changed, 50 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2518f1d
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "fig/link-util",
+ "description": "Common utility implementations for HTTP links",
+ "keywords": ["psr", "psr-13", "http", "http-link", "link", "rest"],
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "PHP-FIG",
+ "homepage": "http://www.php-fig.org/"
+ }
+ ],
+ "require": {
+ "php": ">=5.5.0",
+ "psr/link": "~1.0@dev"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.1",
+ "squizlabs/php_codesniffer": "^2.3.1"
+ },
+ "autoload": {
+ "psr-4": {
+ "Fig\\Link\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Fig\\Link\\Test\\": "test/"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0.x-dev"
+ }
+ }
+}
diff --git a/php-fig-link-util-get-source.sh b/php-fig-link-util-get-source.sh
index ba71f5d..4ad1051 100755
--- a/php-fig-link-util-get-source.sh
+++ b/php-fig-link-util-get-source.sh
@@ -43,6 +43,8 @@ print "GIT_REPO = $GIT_REPO"
print "GIT_DIR = $GIT_DIR"
TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
pushd $TEMP_DIR
print "Cloning git repo..."
@@ -51,6 +53,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
@@ -58,7 +61,6 @@ pushd $TEMP_DIR
mv $GIT_DIR $TAR_DIR
- TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
print "TAR_FILE = $TAR_FILE"
[ -e $TAR_FILE ] && rm -f $TAR_FILE
diff --git a/php-fig-link-util.spec b/php-fig-link-util.spec
index 7cd0a6b..faef65f 100644
--- a/php-fig-link-util.spec
+++ b/php-fig-link-util.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-fig-link-util, from:
#
# Fedora spec file for php-fig-link-util
#