summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-09-10 07:40:41 +0200
committerRemi Collet <remi@remirepo.net>2018-09-10 07:40:41 +0200
commit9827bb884b8dfa2f94f92bba4f354ac077514bb2 (patch)
treec45daeea302aa825cf5efef27c3131d2b3e8146c
parent3d67ad3b391b9b4f17fb8c7a13886550c7a78556 (diff)
update to 3.0.2
sources from git snapshot
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-felixfbecker-advanced-json-rpc3.spec14
2 files changed, 38 insertions, 4 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..37cb6a2
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-felixfbecker-advanced-json-rpc3.spec b/php-felixfbecker-advanced-json-rpc3.spec
index abfe0fd..2bc3cc9 100644
--- a/php-felixfbecker-advanced-json-rpc3.spec
+++ b/php-felixfbecker-advanced-json-rpc3.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 29f1d8c2c17f8c04f9768d382b72aeeb0715ebb8
+%global gh_commit 09fed304fc802b82be939a64691c09443c97defa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner felixfbecker
%global gh_project php-advanced-json-rpc
@@ -21,13 +21,15 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.1
-Release: 2%{?dist}
+Version: 3.0.2
+Release: 1%{?dist}
Summary: A more advanced JSONRPC implementation
License: ISC
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+# Create git snapshot as tests are excluded from official tarball
+Source1: makesrc.sh
BuildArch: noarch
%if %{with_tests}
@@ -143,6 +145,10 @@ exit $ret
%changelog
+* Mon Sep 10 2018 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2
+- sources from git snapshot
+
* Mon Jan 22 2018 Remi Collet <remi@remirepo.net> - 3.0.1-2
- missing dependencies